17 Replies Latest reply on Mar 3, 2019 8:49 PM by Annette Panopio

    All Solidworks icons Grayed out

    Scott Baugh

      I just got a call from a user that said SW won't save. I logged into his computer and when I went to File from the pull down menus... almost all the icons are grayed out. Cut, Copy, and paste are even grayed out. Anything that is Solidworks related is gray including add-ins. 3rd party add-ins are not grayed out and are selectable.

       

      This is not the first time I have see this and the only solution is to stop and restart SW. I looked at all the normal locations that turn off some functions... Large assembly Mode for example... it to grayed out.

       

      User said he was just working and when he went to save it he noticed that it was grayed out. One thing I noticed is on of the 2 parts had a Rebuild light and the rebuild light icon was not selectable, nor did Ctrl-Q work. It was like SW was locked up, but still running.

       

      Has anyone else seen this problem?

       

      Regards,

      Scott

        • Re: All Solidworks icons Grayed out
          Charles Culp

          Was he:

           

          1. In an assembly.

           

          2. with a part in rollback state

           

          3. and there was some sort of dialog box "do not ask again" that was causing the problem?

           

          I forget the details... but if it happens again you could check Tools>Options>Advanced. and see if there is anything of concern. I had something similar, and I really just don't remember the details. I do remember that it was tied to a part in rollback state, and I couldn't undo the rollback state because it was automatically accepting some dialog box.

          • Re: All Solidworks icons Grayed out
            Adrian Velazquez

            He probably has a Dialog Open and Minimized, usually the Custom Properties Dialog or the equations dialog.

              • Re: All Solidworks icons Grayed out
                Scott Baugh

                I know it sounds like a Dialog box to me too, but there wasn't one readily available to select. It was grayed out and no where to go. Just spoke to the user again and he had to Force close SW, it completely locked up. Do note that I could still pull down menus and go where ever I wanted to, but I could not select any of hte SW icons... usually with a Dialog box you cannot click inside of SW without being Dinged by the system

                 

                At best a Dialog was suppose to appear, but didn't and locked SW icons out, but not the menus

                 

                 

                I like Rajat Jain idea of a macro that might unlock it, if the Macro's is available... of course I will have to figure out how to write said macro, but its worth a try.

                 

                Thanks for everyone's input! I will have to see if this happens again and try and capture a video of what it allows me to do versus what we see.

                 

                Cheers everyone!

                Scott

              • Re: All Solidworks icons Grayed out
                Rajat Jain

                Scott,

                 

                I am not sure if this will be of any help but you can still try it.

                 

                I have been writing add-ins in SW since last few years. When we use ModelDoc2::Lock(), the SW interface locks and displays behavior similar to what you are observing. In my case, it has happened many times when an error aborts the command abruptly and hence ModelDoc2::unlock is Not called. The simple qorkaround is that you create a small macro and write swapp.activeDoc.Unlock(). Running this macro may solve the issue.

                 

                Hope it helps!!!

                 

                Rajat Jain

                  • Re: All Solidworks icons Grayed out
                    David Brukardt

                    Rajat,

                    Wrote a macro that locks SolidWorks.  Found that I could not run your unlock macro because the run macro icon was greyed out.  But I came prepared.  I converted your unlock macro to run in an Excel VBA macro and I was able to unlock SolidWorks using it.  I suppose the best thing to do is write a vb.net standalone to eliminate having to open excel.

                  • Re: All Solidworks icons Grayed out
                    Peter Kirk

                    I've had the same issue 2 and 3 part assembly running Tolanalyst. Recalculated, then wanted to see tolerance on part SW 2014 locked up. I can not run a macro any other suggestions?

                    • Re: All Solidworks icons Grayed out
                      Mike Owens

                      I am having this exact problem as well right now (Solidworks 2015 x64 SP3.0). I was hoping the Macro would work for me as well, but my macro button to "Run" a macro is also greyed out. I tried opening a new part and solidworks functions normally so I tried running the macro with that part open, but unfortunately it did not effect the documents that are open (all tools and buttons are greyed out, will not let you rebuild, ctrl+q does nothing, cannot save, cannot close solidworks but is not frozen and you can select your drop down menus, etc as previously mentioned, but you just cannot select any tools that will actually do anything.) Looks like I will be force shutting down solidworks and losing all of my current work open. Hopefully someone might be able to add additional info to this post to help others who stumble across this in this future if there is a work around or how to use the macro? I usually don't chime in, but love the forum and all the great answers, so thank you guys as well!   

                      • Re: All Solidworks icons Grayed out
                        Justin Eaton

                        Having same exact issue as Mike Owens with service pack SW15 SP4.0.  Anyone come up with a fix?  Macro won't work because the macro commands are grayed out too.

                        • Re: All Solidworks icons Grayed out
                          Kevin Terrell

                          I just ran into the same problem.

                          Rajat's solution does work, but no instructions were given on how to use the Macro.

                           

                          1.  Open a new part (which will not have the problem).

                          2. Go to Tools -> Macro -> Edit (That is if you can download Rajat's program.  If you cannot download the program pick New instead and erase everything that is on the main and paste the following macro:

                          Option Explicit

                          Dim swApp As SldWorks.SldWorks

                          Dim oModel As SldWorks.ModelDoc2

                          Sub main()

                              On Error Resume Next

                              Set swApp = Application.SldWorks

                              If Not swApp Is Nothing Then

                                  Set oModel = swApp.ActiveDoc()

                                  If Not oModel Is Nothing Then

                                      Call oModel.UnLock

                                  End If

                                  Set oModel = Nothing

                              End If

                              Set swApp = Nothing

                              If Err.Number <> 0 Then Err.Clear

                          End Sub

                           

                          3. Now pick the part that is having the problem. (By doing this, you are telling the macro that you what the macro to affect that part file)

                          4. Now go back the Macro Window and run the Macro.

                           

                          The key is step three, you must activate the problem part before running the macro.

                          • Re: All Solidworks icons Grayed out
                            Annette Panopio

                            Make sure you are not in an exploded view in configurations.