AnsweredAssumed Answered

Intel HD3000 software OpenGL locked

Question asked by Zana Ghaderi on Mar 29, 2011
Latest reply on Mar 30, 2011 by Zana Ghaderi

Hello,

 

I have recently bought a new Macbook Pro 13" 2011 model. This includes a second generation Intel i5 2415 processor with an Intel HD3000 integrated graphics card. Intel claims this should be equal to the old Nvidia 320M used in last years Macbook Pro. As I've seen other people use Solidworks without problem on those machines I am assuming this has nothing to do with the capabillity of the graphicscard.

 

Now, to start using Solidworks 2010 I installed Windows 7 Professional 64bit version via bootcamp. Everything went well and I see no problems with any drivers in the device manager. When using Solidworks I get very very slow performance. Everytime I'm in an assembly and my mouse hovers over a part it 'traces' the edge lines in orange and does this every time something changes in the view(i.e. tilting view,zooming). This is supposed to be instant in normal use as it is used to highlight which face is about to be selected. Because of this specific 'tracing' everything is slowing down while zooming,moving etc.

 

This made me very suspicious and looking into the settings. The culprit: Software renedered OpenGL. I can't turn it off as it's greyed out.

I then updated the drivers thinking that was the problem. Intel HD 3000 drivers released on 3/10/2011 which is two weeks ago. This didn't affect anything.

I tried everything suggested here on the forums. Opening preferences while no part is open, restarting windows, reinstalling Solidworks, removing registry.

 

Other discussion suggesting the Intel HD3000 should work:

https://forum.solidworks.com/message/206032

 

I checked Intel's website and it DOES support hardware acceleration. I tried an old game I had and everything went well and the hardware acceleration was working. So I am clueless what to do to be able to use hardware acceleration instead of the slow software OpenGL for Solidworks.

 

Summary:

Solidworks not allowing the Intel HD3000 to use hardware acceleration. 'Use software OpenGL' is ticked and greyed out. Drivers update didn't work. The Integrated graphics card is working and that is not the problem.

 

Extra:

A screenshot of the Intel Control panel while using Solidworks showing clearly that its not running on hardware acceleration.

http://img26.imageshack.us/img26/6080/intelu.png

 

A very long post but I like to include all my information as I need this fixed fairly quickly.

 

Any suggestions?

Outcomes