AnsweredAssumed Answered

EPDM API Library not found Problem

Question asked by Morgan Friday on Feb 1, 2011

I have recently upgraded to SW2011 and EPDM2011 and have found that a macro to check-in a file no longer found the epdm library and wouldn't go past "Dim vault As IEdmVault7".

The reference wasn't missing, but was pointing to (32bit)"C:\Program Files (x86)\PDMWorks Enterprise\EdmInterface.dll"

 

I tried pointing the VB reference to (64bit)"C:\Program Files\PDMWorks Enterprise\EdmInterface.dll" but VB didn't seem to take it.

 

I finaly renamed the (32bit)-EdmInterface.dll and copied the (64bit)-EdmInterface.dll into the (32bit)"C:\Program Files (x86)\PDMWorks Enterprise\" folder and it worked fine. Has anyone seen this before or have any idea whats going on. This macro is run on multiple computers and I would like a better solution than copying EdmInterface.dll over from one folder to another.

 

UPDATE:

I undid everything and it still works so somethign was funny with the Library Refs, now when I try on another computer I find they have "\SolidWorks Enterprise PDM\" and no "\PDMWorks Enterprise\". Clean uninstalls needed!!

Outcomes