7 Replies Latest reply on Mar 8, 2011 11:27 AM by Paul Marsman

    Useful quirk now gone

    Jeff Hamilton

      For the last few years there has been a useful quirk in the insert model dimensions command.  You could actually start the command and show all dimensions for a model or feature. Then while that command was still open you could delete the dimension that you wanted to keep and "X" out of the command. Then only that dimension would show up on the drawing.

      Sadly, now that has been fixed in 2011 SP 2. You have to show all the dimensions for that feature, then delete all the dimensions except the one you want to keep. Technicall more accurate, but definately the long way around.

        • Re: Useful quirk now gone
          Paul Marsman

          Jeff,

            I'm soon to be updating to 2011 SP2 from 2010 SP4... but I don't see how this works in 2010?  I guess I don't follow your process for deleting dimensions then X out of the command... when I X out... it quits and doesn't do anything.  Could you elaborate at all?

            • Re: Useful quirk now gone
              Jeff Hamilton

              Apparently is a 2011 thing, not an SP 2 thing. We haven't been using 2011 all that long and it apparently never came up before. 

              Essentially it worked backward from the intended command. Under the command Insert model dimensions you could delete the dimensions that you actually wanted to see. Then when you canceled out of the command those dimensions would reappear. Kind of odd, but it kept you from having to show alot of dimensions associated with the model and then deleting the unwanted ones later.

               

              Perhaps it was our installations, but it worked well.

              1) In a drawing view select to Insert model items for a feature or the whole model.

              2) A number of dimensions should show up on screen. Do not select the check box to complete the command.

              3) Delete an inserted dimension. (One that you actually want to use.)

              4) Close ("X") out the command. The dimension should reappear.

                • Re: Useful quirk now gone
                  Paul Marsman

                  wow, never tried that before, but it "works".... I would consider that a bug.  If you do that your mouse icon changes whenever you hover over a dimension from that point forward to what the icon is during the model items command.  So it looks like it's stuck halfway out of the command.  Not that I would use it in that way (and won't be able to after this week anyway) because we clear the "mark for drawing" option on anything we don't want in the drawing in the first place.

                    • Re: Useful quirk now gone
                      Jeff Hamilton

                      Had to be a bug so I can't really complain. But it worked nice while it lasted.

                        • Re: Useful quirk now gone
                          Jeff Hamilton

                          As it stands now there is no useful way to select model dimensions for insertion into your drawing. You select the feature and you get them all. Then you have to delete the ones you don't need. not to mention that it relocates all of the dimensions you already had in the view. This is a regression! At least allow us to select the ones we want to use rather than bringing them all in.

                            • Re: Useful quirk now gone
                              Paul Marsman

                              They do give you the option to specify dimensions for drawing or not.  It's an option in your system options tab under "Drawings" (second check mark).  Depending on whether you insert more than 50% of your model items or not, select the appropriate default in your options for marking dimensions for drawing.  If you insert more than 50% then leave it checked, if not, then uncheck it.  Now when you are modeling you can specify what dimensions to mark for drawing or which ones to unmark for drawing. (you can even multi-select and change the option for the dimensions in your RMB menu)

                               

                              The only way I have found to keep dimensions where they are in your drawing when inserting model items after the first time is to check the option to use sketch location.

                                • Re: Useful quirk now gone
                                  Jeff Hamilton

                                  That's has been around for awhile, but never seemed to work that well. I stopped using it after I went to the trouble of marking the dimensions for the drawing and still had them not show up.

                                  This seems like it should be a no brainer. You pick the feature (or model) whose dimensions you want to see in the view. It shows you everything marked for drawing (or all). Then you select which ones you actually want to use. As it is, you may have several different views where you need to show those dimensions. Picking on the model or feature now gets you EVERYTHING. (Many times everything except what you need to see, but that's another issue.) Then you have to delete what you don't want to use in that particular view.  It also relocates all the existing dimensions, even though that option is not switched on.

                                  Is it so hard to make Solidworks drawing friendly?