AnsweredAssumed Answered

SolidWorks 2011 Crashes on "file open" execution

Question asked by Tim Zollers on Jan 6, 2011
Latest reply on Nov 4, 2015 by Quinn Millsbury

Hello All,

 

I've been running various versions of Soliddworks (2007 - 2011) on a Toshiba Sattelite x205-SLi, 32-bit XP Pro / Vista Home and Windows 7 (incrementally) Core2 DUO processor, 4GB RAM and dual nVidia GeForce 8600M cards.  Except for not being able to use RealView Graphics, the laptop worked PERFECTLY on the OS's, through SW 2009.

 

About a 14 months ago, I started using Win7 32-bit exclusively with an install of SW2009 and the various SW service packs.  Everything was great until I upgraded to 2010... and it has only gotten worse with 2011.

 

With 2010, SW would start fine, but the program would crash when I tried to open a file or start a new part.  The program would hang for about 10 seconds, crash and the program would restart.  I would then have no problems until I started a new session of Solidworks, usually the next day or later.

 

Running 2011 has proved to be even MORE of a problem.  I did a remove of 2010 and installed 2011 with the downloaded updates from the Solidworks website.  The problem reared its ugly head on the 2nd or 3rd restart of SW2011, but this time, the crash would repeat itself over and over, preventing the ability to open any files.

I uninstalled the software and used a registry-cleaner tool, and reinstalled 2011 to a fresh directory.  Thinking it might be a conflict with Windows Explorer, I did not install Solidworks Explorer or the PDM product.  The program worked fine for one or two sessions-- then the problem came back.  Software crash with "open file" and repeated crashes for 3 or 4 restart attempts.  I found that if the "send a report to Solidworks" dialog box popped up with the option to restart the program-- it would run fine.  Until the next "new" session of SW.

 

Running the Rx program gives ALL green checkmarks except for the video card (expected), but c'mon.... its an nvidia card and I never had any issues before 2010!

I checked the display setting in SW and OpenGL was unchecked, and checking it did not help.

 

However, if I am in Windows Explorer and choose to open a file using "open with", SW launches and the file opens fine.  If I close the newly opened file and try to open a new file-- SW again crashes.  IF I leave the part file open (in session) and try to open a new file through the SW menu-- the file opens fine.

 

I don't know if there is something going on in the registry, if there is a faulty DLL or what the issue is.

 

I know every is going to say to contact my VAR, but this is a "home install" using one of our corporate seats on my personal laptop.

 

The video cards can't be upgraded (believe me, I've checked) and my only other option is a newer business class workstation, which most of you probably know isn't cheap!

 

I'm wondering if anyone else has experienced this type of crash or if it is limited to me!

 

Thanks in advance for your response....

 

Regards,

 

Tim Zollers

Outcomes