9 Replies Latest reply on Nov 18, 2010 4:15 PM by Kelvin Lamport

    Invisible dimension text

    Paul Klock

      This all of a sudden started happening to me in 2010, and now is suddenly doing it in 2011 as well.  When I add a dimension, the text disappears.  You can still click it, if you remember where you placed the text, but it is invisible.  I have to right click the dimension and go display options show parenthesis on each dimension, just so I know where I can double click to change the value later.  Then it shows the parenthesis, but the text is still invisible.

       

      This is infuriating, as it makes modifying sketches much more difficult then it should be.  How can I fix this?  I am using an ATI FireGL v3300 on the recommended 8.583 driver.

       

      Thanks for the help!

        • Re: Invisible dimension text
          Scott McFadden

          Tyler,

          Is this happening to all of your drawings or just one?

          Are other experiencing this?  If not you can copy their settings and install them on your machine.

           

          Do you happen to remember the exact thing that you were doing when this started happening?

          • Re: Invisible dimension text
            Troy Peterson

            One thing you can try is to do a full uninstall of your video drivers where you are just running VGA drivers, then reinstall fresh. Also you might want to download the drivers again before the reinstall just in case there is something wrong with the current file you are using.

            • Re: Invisible dimension text
              Paul Klock

              It happens in all sketches of all features of all parts.  Including ones that were created before this started happening.

               

              I wasn't doing anything unusual when it started happening.  I did a save as copy of a part within an assembly, inserted the copy back into the assembly, and started modifying one of the sketches, which had its text dissapear.  No settings were changed.

               

              I have tried reinstalling the video files, didn't seem to make a difference.  Other people do not have this issue.  I will try reinstalling and copying settings again, but I have a feeling even if it fixes it it will just happen again down the road.

                • Re: Invisible dimension text
                  Scott McFadden

                  Make sure you save your own settings first mefore you copy over someone elses.

                   

                  Maybe it is time to uninstall Soldiworks, clean out the registry and reinstall it.

                  What service pack are you running?  Did you look on the Solidworks portal to'

                  see if there is an existing SPR out on this issue?

                  • Re: Invisible dimension text
                    Charles Culp

                    Tyler,

                     

                    Is this in part files, or in drawing files?

                     

                    If it is in part/assembly files, go to the top of your feature tree, right click on the Annotations folder, and make sure "display annotations" is checkmarked. Then, go to to the Menu bar, and select View>All Annotations, and make sure that is checkmarked.

                  • Re: Invisible dimension text
                    Kelvin Lamport

                    Are you using a "brand name" computer (Dell, HP, Lenovo, etc)

                    Which OS are you using?

                     

                    The V3300 and 8.583 driver is not listed for SW2011 It is only for XP and Vista with SW2010, for generic brand computers.

                     

                    Maybe your card is dying. Have you tried enabling the Use software OpenGL option?

                      • Re: Invisible dimension text
                        Paul Klock

                        These are in part files. Sketches.

                         

                        Changing the annotations settings didn't make a difference.

                         

                        We use custom computers here, so no brand name.  It is listed for 2010, and I had the exact same problem in 2010 that I am now having in 2011 as well.

                         

                        The use software OpenGL option is grayed out, does that mean I am already using software rendering?  I do not have the option for real view.

                         

                        I have attached a screenshot, you can see on the upper right dimension I have clicked show parenthesis, just so I know where to click to change a dimension.

                         

                         

                         

                        With that being said, I think I found a work around.  I enabled the Display "Dimensions flat to screen" option in display/selections, and all the text is now visible.  At least I can use it now, still not sure what caused it in the first place though.

                          • Re: Invisible dimension text
                            Scott McFadden

                            Tyler,

                            You know I was so close to suggesting the flat to screen option in my original posting,

                            but it didn't do anything that represented what you were experiencing so I didn't suggest that.

                             

                            This might sound weird, but your dimensions wouldn't happen to be the same color as your

                            screen background would they?  I know, crazy thought, but I had to ask!!!

                             

                            Did you happen to install someone elses settings?  Did that do anything for you?

                            • Re: Invisible dimension text
                              Kelvin Lamport
                              The use software OpenGL option is grayed out, does that mean I am  already using software rendering?  I do not have the option for real  view.

                              If the Use software OpenGL option is selected and greyed, that means your card is not capable of supporting OpenGL. But you have a FireGL V3300 card which should be capable, so if it is selected, that would indicate the card is pooched.