3 Replies Latest reply on Oct 10, 2010 4:35 AM by 1-TJ4946

    Solid Bodies Can Not Be Found

    Connie Harrison

      I have had many instances of the error ‘Cannot Find Solid Bodies associated with the material’.  This error has occurred with small or large models.

       

      The error occurs when trying to edit Solid Materials definition or when starting to solve a new or revised model.  In this case it is attempting to add Tube3<3> to Solid material Steel Stainless 321.

      Other components have had solid materials edited without errors.

      Fluid opening definitions appear correct.

      Model volumes have been checked.

       

      Things tried:

      Assembly rebuilt.  This has corrected error sometimes. (?)

      Existing Solid Material definition deleted and started a new Solid Material definition.  This appears to correct this error sometimes. (?)

      Saved and reopened assembly.

      Project rebuilt.

      Tube3<3> opened , rebuilt saved and assembly reopened.

       

      In this specific case, the error was corrected by suppressing the HE Box 3 component, selecting the Tube3<3> component and defining Solid material.  Then the HE Box 3 was unsuppressed and Solid Material defined for it.

       

      This error appears to be random and the correction often seems to be the random trial of many things until the error goes away.

       

      Can you provide any explanation?  The model files can be sent if needed.   

        • Re: Solid Bodies Can Not Be Found
          Ron Reiners

          I know your frustration. I had the same problem last week. I never did find the exact cause. I had updated a part file and then made a bunch of changes to the assembly (part locations, spacing's, and mates). I had turned off Flow so I wouldn't get a ton of error messages for every new mate and adjustment. When I turned flow on and went to correct material properties I ran into the same problems.

           

          My only solution was to dump the assembly and part file and start over with backup files. Avoiding the change to the part file and leaving Flow turned on I was able to make all of the adjustments. I did one or two at a time and then performed a Rebuild. If I ran into a rebuild error I would dump the file and reload the last good file. I eventually able to make all of the changes but never did find the root cause.

           

          Being faily new I have run into several unexplained problems similar to this. I have atleast one at tech support that still has not been figured out. I think Flow is a little more touchy than most programs. Maybe it is just a sequence thing. Hopefully it will get solved.

          • Re: Solid Bodies Can Not Be Found
            Chris Michalski

            I've seen this in the past (not sure what I did to cause it)

             

            the solution was always to edit each material definition - make sure it still includes all of your intended bodies.  Sometimes everything was still correct and you just hit ok.  In a given material definition SW somehow lost track of one of the solid bodies - sometimes all you have to do is edit a body and it changes the name of the body (i.e. from Extrude <13> to Extrude <14> because you added another extruded feature).

             

            Or if you delete a body it still has it in the list of bodies that a material should be applied to so it complains that it is trying to apply a material to a body that no longer exists. (this is when simply editing and clicking ok solves it)

            • Re: Solid Bodies Can Not Be Found

              Do you insert the  parts in the assembly by 'insert the New part' instead of  'insert Excisting apart/assembly ' ?

              If you complete the parts by 'insert the New part', you'd better save externally.see appendixes.