32 Replies Latest reply on Jun 7, 2017 3:23 PM by John Stoltzfus

    Item number callout shows *

    Charles Culp

      Anyone know how to fix this?


      I have an assembly with a sub assembly. That sub assembly is shown in the BOM as Item 2. The Balloon points to the sub assembly. It has a quantity of -1, item number of *, and the custom properties all link properly.


      If I right click on the drawing view, it is linked to the correct bill of materials. This happens in all drawing views. Other drawing views have components that correctly link to the BOM item numbers. I have a different configuration shown on this same drawing. It has a different configuration of the same sub assembly in it, and it links properly. I have also tried using auto-balloon, and that just creates another balloon to the part, with the same issues.


      BalloonFail-ItemNumber.png  BalloonFail-Quantity.png

        • Re: Item number callout shows *
          Wayne Tiffany

          Generally a * shows up in the balloon when either the part you balloon isn't in the BOM, or the part in the view is not the same config as the one in the BOM config.



            • Re: Item number callout shows *
              Charles Culp

              Wayne, et al,


              As you can see below, the BOM references both configurations that are in this assembly. There are two sets of views for each configuration. The configuration shown in the image below is for the configuration referenced in the drawing view that I am trying to balloon. All of the other components (in the other drawing views of this configuration) link properly.


              So to answer your question specifically, 1: My part is in the BOM as shown. 2: Both of the configs (and there are only two) are in the BOM.



            • Re: Item number callout shows *
              Josh Brady

              This one took me a while to figure out.


              1. Set your BOM properties configuration grouping to "Display configurations with the same name as one item number.
              2. Open up your subassembly and go to the Configuration Manager.  In each configuration's properties, change "Part number displayed when used in a bill of materials" dropdown to "User specified name", and then type a name in the box.  This name must match on all configs that you want to appear as one line item. 


              You can't use "Document Name", "Configuration Name", or "Link to Parent Configuration" in that dropdown for this to work.

              • Re: Item number callout shows *
                Jim Moder

                Let me tell you all that my original post from Nov 24, 2008 is back alive, https://forum.solidworks.com/thread/19922

                and I'll say briefly here that I had no problem with this in SW 2007 and when upgraded to 2009, it became a big problem, then 2010 with the service packs fixed that.

                Well now when I open the work that I just did with SW 2010 open with SW2011, vualla THERE BACK. I have the prints that prove they were not * before the 2011 upgrade.

                They missed the SPR 461990  which was called "Balloon attached to a subassembly in which components are excluded from the BOM shows an asterisk, customer would like subassembly number"

                Freekin idiots.

                • Re: Item number callout shows *
                  Brian McEwen

                  Any luck with 2012?  We will probably switch from 2010 some time this year.  We are having similar problems mentioned above - mainly getting sub assy balloon to show up.

                    • Re: Item number callout shows *
                      Charles Culp



                      I can confirm that when I open up a drawing known to have this issue, I can still get it to display the incorrect thing when I switch BOM Part Configuration Grouping. Because of this, please make sure you notify your reseller that you are having this problem so it gets reported as a bug.


                      We have found a way to get around this:


                      To summarize the problem, if you have a drawing and assembly file with multiple configurations that also references multiple configurations of the same part file, the BOM may not appear correctly. You may get asterisks in the balloons when you add balloons to the part with multiple configurations. You may also not get the proper part configuration grouping as defined in the BOM PropertyManager. Here are the correct steps to be successful every time.


                      1. You can add balloons at any time. Just make sure that your drawing views are referencing the correct & current BOM by right clicking on it and choosing Properties>View Properties>Balloons>Link balloon text to specific table.


                      1. Create a BOM with the following settings:

                                You can use any drawing view as the reference for the BOM

                                Configurations: Only select one configuration (whichever is the config used in the reference drawing)

                                Part Configuration Grouping: You must have Display as one item number checked.

                                You must use the first option (config of same part as sep. items)


                      1. After creating the BOM you can then re-edit the BOM properties and then add the additional configurations.


                      1. You can never change the Part Configuration Grouping. Switching to the third option (config of same name as one item) creates asterisks. Switching back to the first option then makes the item numbers all remain the same. So you cannot ever change this, or you have to re-create the BOM.



                      And this forum's goofy numbering system made them all 1's, sorry!

                        • Re: Item number callout shows *
                          Brian McEwen

                          Charles, Thanks for going over that. 


                          Unfortunately, you guessed it, that didn't work for me. I went over the steps several times, and created a new drawing file from scratch.   Reading around the forum it sounds like the inconsistent manifestations of this problem is partly why it still exists.  Smith said here "if the configuration names of both the sub and top level assy are not the same, it gives you the *", I haven't found that to work for me either, although I may have missed a few sub assy that are not called Default config. 


                          I actually only have one config at this point for the highest level assy, and the Part config group settings you mention are the ones I want.  Right now I do have one of the sub assy set to a Speedpak config, not sure if that could cause other weirdness. 


                          If I uncheck "Link balloon text to specified table." the asterisk go away, but I also get numbers over 200 (so it must be doing only parts), when there are 88 items in the Top Level BOM, which I think is correct due to Hide/Promote settings I've already set on some sub assy. 


                          I'll go back to the Parts type BOM, I can make it work. I'll have to stop using the speedpak (since there is no Hide children when used as a sub assy  option for it). 


                          I'll let our VAR know about this issue. 

                            • Re: Item number callout shows *
                              Charles Culp

                              Here is the other thread where I went into further detail on what I am seeing.



                                • Re: Item number callout shows *
                                  Brian McEwen



                                  I looked over that Asterisk Bubble Number thread.  I don’t think anyone mentioned the following discoveries. 


                                  I worked on this with my VAR today.  I assume most people are using the default “Top-Level only” BOM Type.  For me Promoted sub assy are often the ones that have * when used with a Top-Level Bom.  As Tom Smith suggested, I’ll avoid Promote.


                                  1) I do not have the asterisk problem when I use a “Parts Only” BOM.  However, then you have to set some sub assy to "Hide" Children (in sub assy configuration properties) so you don’t only get parts.  "Promote" is already taken care of by the default nature of a Parts Only BOM.  


                                  2) Another work around that the VAR suggested is an “Indented” BOM Type with Flat numbering.  I can’t always use the Promote option (sometimes I can), but I can consistently (fingers crossed) use Dissolve on the Indented BOM Left fly-out bar.   I also use Right click Combine Identical components to get the BOM the way I want (plus the feature unique to Indented BOMs of being able to expand or contract the sub assy).  


                                  Interesting finding with some terminology  – when you use Promote you get a note/tag on the sub assy in the Drawing Feature Tree “(Dissolved in BOM)” (you may have to drag the tree bar several inches to the right to see it).  You can right click on the item in the tree and select “Restore In BOM” and it has the same effect as going to the sub assy config and setting it to Show. 


                                  On the other hand, when you use “Dissolve” on a sub assy in the Indented BOM, you do not get this tag. It just puts some symbols on the flyout bar, I think indicating that restructuring occured.  Difference is this is a one time action, not affecting everywhere the config is used.


                                  Anyway that is my current method to handle this problem. 


                                  Thanks, Brian

                                  • Re: Item number callout shows *
                                    John Griesbach

                                    I had a simmilar problem with one component in a configuration showing up as * and my final solution that worked was to go into the other configurations where the component was suppressed and un-suppress them and click exclude from bill of materials and then suppress them again as they were before.  This fixed my problem for some weird reason.  No logic sometimes on why solidworks does what it does

                            • Re: Item number callout shows *
                              Kolburn Kersten

                              Maybe someone already answered this or someone is still looking at this in 2017. But if you go into the assembly model and right click the part that has the * as the item number, there is a box on the bottom right that says "exclude from bill of materials" if that is checked, then you will get a qty of -1 or a * as your item number. Uncheck it, problem solved


                              Hope this helps someone still searching for this problem!