2 Replies Latest reply on Jul 27, 2010 1:00 PM by Charles Culp

    Unwanted stub lines when sketching

    brandon michaelis

      When sketching lines, I often get unwanted stub lines in my sketch.  For example, let's say I sketch a simple rectangle. When the four lines of the rectangle are complete and I go to extrude the rectangle it fails.  I will go check out the sketch only to find a small stub line that I inadvertantly had placed in the sketch.  This happens quite frequently with both me and my co-workers.  Is there a setting within SW that I can change to help reduce this?




        • Re: Unwanted stub lines when sketching
          Dan Eldred

          well when constructing a rectangle you could use the Rectangle Sketch tool, but the problem you are facing is in the way you click.


          To draw consecutive sketch lines you click (pressing and releasing the mouse button), move the mouse click, and repeat.

          To draw a single nonconsecutive sketch line you click (press down without releasing the mouse button), drag the line out to length, and release the mouse button.


          With that said you would probably want to press Escape after you connect the last line of your rectangle or right-click and select end spline. You can however double click to stop sketching but make sure the double click threshold (time between clicks) is set to accomodate your double clicking speed. this can be done in your mouse settings.

          • Re: Unwanted stub lines when sketching
            Charles Culp

            This has been discussed a couple times before, here was one of the threads, I could not find any of the others:




            Don't "double click" to end the square. Just single click. You are accidentally either double clicking, or moving your mouse while continuing to click for that last endpoint.


            I do not know of a setting to adjust the tolerance for how short a line segment can me.