11 Replies Latest reply on Oct 28, 2013 6:20 AM by Kishan K

    True 1:1 prints

    Aaron Tuck

      Does anyone know how to get solidworks to print at true 1:1?

       

      When I print it comes out 1-2mm smaller on most dimensions, but when I scale it up to say 102%, it throws everything out of proportion dimensionally. This is because 102% of 20mm is 20.4mm but 102% of 200mm is 204mm. See the problem here? I can never get a true 1:1 representation of a part.

       

      I need true 1:1 for a pattern maker, because the part has splined curves which are hard to dimension.

       

      It's probably a printer problem, but any help/advice would be appreciated anyway.

       

      Cheers.

        • Re: True 1:1 prints
          Derek Bishop

          I've run into a similar problem recently. I've set up my title block to meet the edge of the sheet border, but the printer cannot print to the border edge and so I have to use scale to fit rather than print at 100 %. This means the dimensions are all printed slightly out of scale and slightly small. The solution is to set up the border of the drawing to be inside the printer margins and use print at 100%.

           

           

          Print.JPG

          • Re: True 1:1 prints
            Kieran Choy

            You need to work out what is causing the problem - your printer (and/or drivers) OR SolidWorks.

             

            Try this - create a test pattern in Autocad or DWGEditor and print it out. If it prints perfectly, the problem is SolidWorks. If they are also not to scale the problem is your printer/driver.

             

            Alternatively, save your drawing to a PDF (use Save As) and print out the PDF. Unless SolidWorks is also screwing up the PDF output, this will determine whether it is SolidWorks or your printer.

             

            If you are still not sure if it is SolidWorks or your printer take the PDF to your local printshop and see what size their's print to.

             

            Also check the options for your printer from Start Menu >> Printers. You may have a calibration test you can run and tweak.

             

            Keep in mind that if your patternmaker is working off a print-out and the lines are .18mm thick he will never be more accurate than that.

            • Re: True 1:1 prints
              Mike Puckett

              We used to try printing 1:1 or at different scales to make clear overlays for the comparator to check parts, and we always got different scale factors depending on what printer we used.  If you think about how a printer works, you are relying on the accuracy of it to print out to scale, and that's where most of the issue will lie.

               

              To overcome this problem we would always add a 1" X 1" square to the print out.  We would then measure that square on the comparator and that would give us a scale factor.  We would then factor that in to our measurement results.

              • Re: True 1:1 prints
                Bernard Julien

                It has been a long time since I tried to print using a true size. Printers are not known to be very accurate.

                All the other posts are correct. First make sure that you are not trying to print larger than what the printer can print. However I suspect that this is not your problem since you are specifying 1:1 scale.

                 

                If you can get to a plotter, there might be a calibration that can be done. In the past we used a plotter that had a calibration capability. You ran a print and then adjusted the scaling to get the exact size that you wanted. I think that the HP designjet still have that capability.

                • Re: True 1:1 prints
                  John Matrishon

                  It is the printer.   I did alot of research into this awhile back when making large patterns.   The main problem resides in the printers ability to hold and accurately advance the paper as it prints. Measure in both directions, you'll notice that the scaling problem is always worse in the direction that the rollers are advancing the paper, and generally pretty accurate in the printer head direction.  What is weird is that this was never an issue in the old Pen Plotter days?  Still can't figure that one out, and HP never had a viable response.   AutoCad accually has a built-in application to account for this known error where you plot out a large rectangle of known size, print it, measure it, then give it the CAD size, and measured size and it creates a plot file that scales each plot by that amount.   And even that doesn't really work.   Laser jets seem to work fine, but larger format printers all are prone to this.   Whew.....this turned into a rant of some sort.

                   

                  So if you can fit your screens on a laser, I say try it.

                    • Re: True 1:1 prints
                      Daen Hendrickson

                      We tried to overcome this on some template prints by exporting to AutoCAD and using the plot scaling capabilities. Since we don't have an in-house large format printer, we had to outsource the print job. One of the biggest hurdles to success was explaining what we were after to the 17-year old at Kinkos / Insty-Prints / UPS / Alpha Graphics / Local architectural print house....

                       

                      We too found that the off scaling was different depending on direction.

                       

                      The solution was pure luck!!! We happened to find a printer at a neighboring firm that just happened to have it's planets aligned for the day and the resulting plot with our up-scaled AutoCAD file worked out. Definitely not a repeatable solution.

                    • Re: True 1:1 prints
                      Mike Agan

                      There are 2 settings that can affect this: under properties/effects must be set to % of normal size=100%. Also under page setup scale must be set to 100%.

                      • Re: True 1:1 prints
                        Jeremy Waldner

                        there is an additional step you may have to go through to get 100% printed output:

                        hit the printer 'properties' button and set the layout to 100% as well.

                         

                        (Using a Canon ImageRunner printer here...might have different terminology for other makes.)

                         

                        https://forum.solidworks.com/message/286968

                        • Re: True 1:1 prints
                          Kishan K

                          I also had a similar requirement. I wanted to save the drawing as a pdf and take print of true 1:1 scale. I too got a couple of mm less when i took print out. This what i tried to a satisfying printout. Click save as, in save as type choose .pdf, then go to options, under file format choose DXF/DWG. Under scale output 1:1, check enable and change the base scale to sheet scale.

                          I don't know to what extent i am right but i did get satisfactory results. Hope it helps.