AnsweredAssumed Answered

Preallocation of Memory Resources

Question asked by Mahir Abrahim on Mar 29, 2010

In an effort to increase performance by reducing the use of virtual memory, I have disabled my pagefile.  My PC has 8GB RAM.  I only approach using all 8GB during uncharacteristically heavy use, which includes multiple Firefox tabs/windows, MS Office, multiple large assemblies open, and a large (for me anyways) study running.  This testing was performed when the pagefile was still enabled.  However, now that the pagefile is disabled, I get the error message below.

 

Windows - Out of Virtual Memory

Your system is low on virtual memory. To ensure that Windows runs properly, increase the size of your virtual memory paging file. For more information, see Help.

 

Normal functioning of my computer or the simulation does not appear to be affected.  It seems to stem from Simulation briefly grabbing all the memory it can get its hands on and then releasing it.  This happens even with relatively small studies of ~250K nodes.  At the moment the problem is just an annoying error message, but I'm not sure if it's indicative of a deeper problem or flaw in the FEA code.

Outcomes