AnsweredAssumed Answered

I Broke SolidWorks...The Fun Starts Part 1

Question asked by 1-7UEHFD on Mar 22, 2010
Latest reply on Mar 31, 2010 by 1-7UEHFD

While doing computer maintenance over the weekend, I accidentally broke SolidWorks. I use McAfee for both my security and maintenance needs. This time I accidentally set McAfee to clean out the registry as well. In retrospect I should have double checked make sure the "clean registry" box was not checked. I have never had a problem in the past -except when SolidWorks was involved.

 

When I started my session of SolidWorks, SolidWorks started giving cryptic error messages stating that "SolidWorks could not load because the addin was either missing or not installed". The funny thing was that SolidWorks did load, but several addins-namely Tool box was missing, and would not load when the boxes were rechecked. Past experience told me to do a "repair installation", but this time it did not work. I next did a "system restore" which did not work. This always worked in the past-except when SolidWorks was involved.

 

Now some research on the forums. I tried to delete the SolidWorks Data folderand re-run "repair installation". This did not work, and most interestingly the SLIM crashed and gave some very cryptic messages. It was late and unfortunately I did not think of taking a screen shot to share.

 

Next its time to uninstall and reinstall. I remembered that uninstalling SolidWorks does not really uninstall it. Time to curse the programmers that decided it was a great idea to have Solidworks install itself all over the hard drive, and forget to have the SLIM do the same with the uninstall.

 

Start uninstall and SLIM crashes with those same cryptic messages. Just before crash SLIM asked if I wanted to deactivate PC, and managed to remove icons from desktop, and what appeared to be the main SolidWorks folder on the C drive. Have lots of fun hunting through all folders (including hidden folders) for anything SolidWorks or Dassault Systemes related. Have even more fun searching through the registry searching for all SolidWorks and Dassault Systemes related keys.

 

Flashbacks of same issue with SolidWorks 2007, and being told that I deleted an important registry keyand not to do it again.Flashbacks to VAR confidentally telling me that SolidWorks took care of issue with registry keys. Rember putting in an enhancement request to "harden" registry key from being deleted during disk maintenance and having SolidWorks simply rewrite registry key upon restart when addin is restarted.

 

Create a new enhancement request for the same thing.....Got to bed .

Outcomes