AnsweredAssumed Answered

Hyperthreading or 8pcsr bug in 2010 x64 V2.1? = fatal error

Question asked by Robin Oury on Mar 12, 2010
Latest reply on Mar 14, 2010 by Jerry Steiger

I've been working on this project and made some pretty decent progress yesterday after having half a day of uninterupted creativity.

 

This morning I awoke bright and early ready to get some work done before crazyness began...only to be confronted with SW crashing when I tried to open the result of my work yesterday.

 

Ugh - seriously???

 

So instead of working this morning I've been doing diagnosis and I think I've at least found the cause of this latest bug.

Hyperthreading.

 

I started at the lowest level, opening individual parts, then the next higher assy until I found the combination of items that were causing the crash.

Then after chasing my tail for an hour or two on that, trying different vid drivers, tweaking this or that I tried opening them on my laptop (maybe should have thought of that first.)

The laptop opened them.  Surprise, I thought, wow, better save references and see if that works.

Nope, workstation still crashed on open.

 

This is a barebones, pure stock, fresh install of win7, orifice, sw10, untweaked bios (and it'll take a ton of overclocking.)

 

Then it occured to me, the lappy is a dual core, the station is a quad and HT was enabled, so maybe the 8 pcsrs is killing it.

 

Went into bios, disabled Hyperthreading, started win & sw and opened the file.  Sure enough, it opened fine.  A little sluggish on the graphics display (usually that comes quick) but did open.

 

It's a nice little model too big to attach here, but I have attached the SW rx of the sub assy that seems to be causing the problem.

 

Wanted to try to reproduce it on the lappy with HT, but it does't seem that Hyperthreading option has been written into the bios by HP.  So, I can't say if a quad core is ok, but dual quads is not, or if it's HT that's killing it, but disabling HT is a workarond for this particular fatal error bug in this case.

Outcomes