AnsweredAssumed Answered

Hidden Part In Vault

Question asked by Nathan Underwood on Feb 23, 2010
Latest reply on Feb 23, 2010 by Nathan Underwood

I had an engineer at work that checked in an asembly into the vault that uses other parts in the vault and now we are seeing some serious enomalies. After checking in the assembly, when opened from the local PDM folder, the assembly shows a read only status, but we cannot see the assembly in the vault view. When checking in from the local PDM folder it will allow the owner to re-check in and roll revisions, but yet nothing appears for the assembly in the vault view. When doing a search for the assembly the vault throws an error saying no occurances found. When you generate a report for documents named similar, or with similar descriptions it does not show up in the report. When you select document information from the local PDM folder it shows the folder that it is checked into, but yet it does not display in the Vault view. It is not used in any other assemblies so it would not be hidden under any other document trees. Then we tried checking in the document with a -xx at the end of the name. That document checked in fine and is viewable in the vault. Then we tried re-naming the -xx assembly to the same name and the vault throws another error stating that the name is in use. We even went to the server side and we did find the folder with the assembly with all the revisions, so the assembly has been saved to the server. I don't want to just delete the folders from the server in fear that may cause even more issues. The sub-parts are visible and when checking where used in the document information for them it shows being used in the assembly. I attached a word file with a couple of images from the document information from the vault. The assembly we are looking for is called 3378.SLDASM, but as you can see in the images that does not show up where it should be which is right inbetween 3377.SLDASM and 3378-XX.SLDASM.

What I am trying to get out of this is a way to either be able to take ownership of the assembly and Delete it from the vault, or a way to delete it from the server without causing the vault to crash from having a log error. Is there any one who has had a similar issue, or may know the cause of this error?

 

Thank you in advance on any help provided in helping resolve our issue!

Attachments

Outcomes