AnsweredAssumed Answered

Huge wait time with Pack and Go when including drawings

Question asked by Michael Webster on Feb 18, 2010
Latest reply on Sep 30, 2010 by Michael Duncan

We do a lot of "similar" parts, and often a new job will have us making something close enough to an older part that I use Pack and go to rename and copy into a new folder.

 

This has always worked great (with the exception of the occasional drawing view update bug, but I think that may be fixed now), EXCEPT that when I check "include drawings" Solidworks freezes up for about 5-10 minutes while it "finds" the linked drawings.  Size makes no difference - it takes a long time whether it's just an assembly, three parts and one drawing, or if there are 200 parts and 20 drawings.

 

Now, I am the sole user of SW in our company, so I have never set up any sort of vault or workgroup sharing features, nor do I have indexing set up - indeed it not work for me anyhow since I'm using 64 bit windows and my part and drawing files are stored on the network.

 

Really though, I'm not sure how that could even be relevant - one assembly I just did (that caused me to post this) had:

 

3 parts

1 drawing

 


All files were in the same folder except two identical screws, which were in another folder.  Again, if I do pack and go without including drawings, performance is fine, it's only when I try to include drawings that this occurs.

 

Currently using:

 

Windows 7 64 bit, SW 2010 latest SP

 

Any suggestions?  I've seen comments on slow performance with P&G, but usually these people are working with large assemblies, not what I usually deal with.

 

Thanks

 

 

Update:  I did a pack and go on all the files in this small assembly, to a LOCAL folder (on my PC), then opened THAT assembly, then tried to do a pack and go on it (where every file was starting local and ending local) with the SAME RESULT.  So, I don't think it's network related, but possibly SW explorer/search-related?  Neither of which I have installed - maybe there is some component or process P&G wants to be running, but is missing since I don't have those options installed, and it finally times out and does without?

 

Thanks

Outcomes