22 Replies Latest reply on Mar 28, 2018 11:20 AM by Bret MacKie

    how to prevent autoinsert centerlines?

    Krzysztof Grzebieniowski

      when I click outside view during centerline mode

      SW inserts all centerlines in that view ,

      for me it is annoying , how to stop that (trick?) simply   switch off ?

        • Re: how to prevent autoinsert centerlines?
          Deepak Gupta
          Open up your drawing template. Go to Tools > Option> Document Properties > Detailing and under Auto-insert on view creation, uncheck Centerlines. Save your drawing template.
          • Re: how to prevent autoinsert centerlines?
            Tom Strohscher

            I agree this is a silly option to auto centerline everywhere.  It typically gets me when I make weldments with angle iron.  Who needs a centerline on every fillet of a structure member.

             

            Has anyone put in an enhancement request?

              • Re: how to prevent autoinsert centerlines?
                Peter De Vlieger

                The closest I can find is

                 

                SPR #:
                544254

                 

                "It should be possible to decide whether a center line should be applied to a feature, a component or the whole assembly"

                 

                Else, if you make an additional one, let me know and I'll vote for it !

                  • Re: how to prevent autoinsert centerlines?
                    Dwight Livingston

                    I prefer 544294: User should be prompted or have the ability to cancel creation of centerlines for all components when centerline command is active and a drawing view is pre-selected or selected.

                     

                    Sometimes I attempt to apply a center line to a single feature, but I slip and center-line the whole view. This produces so many obscure center lines that it is easier for me to close the drawing and reopen what I had saved, even though I must redo work, than to chase down all those center lines. Having done this twice today, I really want a fix to this. As this enhancement request says, allow a undo or give me a warning message (with a "don't show again" option).

                     

                    Vote for 544294

                      • Re: how to prevent autoinsert centerlines?
                        Dan Pihlaja

                        Interesting.

                         

                        I have this feature in the CENTER MARK tool:

                         

                        SW 2015 Sp5

                         

                        Unless I check one of those boxes, I can't make it auto insert center marks.  I clicked on Center Mark tool and went click happy and nothing was auto inserted.

                         

                        However for he CENTERLINE tool,

                         

                        Even though it says "Select the auto insert option" it doesn't work the same way the center mark tool works.

                        A single click off the edge of the bloody hole will add centerlines all over the place.  Even on holes that I can't see in that view.

                        • Re: how to prevent autoinsert centerlines?
                          Deepak Gupta

                          Undo works well for me most of the time I encounter this issue.

                          • Re: how to prevent autoinsert centerlines?
                            David Nelson

                            Dwight Livingston wrote:

                             

                            I prefer 544294: User should be prompted or have the ability to cancel creation of centerlines for all components when centerline command is active and a drawing view is pre-selected or selected.

                             

                            Sometimes I attempt to apply a center line to a single feature, but I slip and center-line the whole view. This produces so many obscure center lines that it is easier for me to close the drawing and reopen what I had saved, even though I must redo work, than to chase down all those center lines. Having done this twice today, I really want a fix to this. As this enhancement request says, allow a undo or give me a warning message (with a "don't show again" option).

                             

                            Vote for 544294

                            Its gotten my me.  we put a Isometric view of the part/assembly in the upper right corner of the drawing sheet.  Where it gets me is I will go to add a center line in say the front view, just one line by clicking the outer edges.  Well it works fine for that view, but that ISO will have every place you can put one will have one.  Some will look like a Porcupine.   It does not do it all the time.

                      • Re: how to prevent autoinsert centerlines?
                        Bret MacKie

                        How is it possible, that 8 years after the issue was first raised, this is still an issue? The software does an automatic insertion across the entire assembly in the view no matter what your settings are set to. So it just happened to me again, (this issue has plagued me since 2012) I go to insert a single centerline and the next thing you know my machine is locked up for 5 minutes, and I have 10,000 centerlines on my assembly, and there is NO UNDO.   I just lost a drawing due to this bug, it was faster to start the drawing over, rather than to go and and delete 10,000 centerlines.  Seriously, how hard is it to have a pop-up to confirm that yes, I do want 10,000 centerlines, or no, only one is fine thank you.

                          • Re: how to prevent autoinsert centerlines?
                            Glenn Schroeder

                            Welcome to the forum.  Are you absolutely sure you didn't have the drawing view selected when you activated the "Centerline" tool?

                              • Re: how to prevent autoinsert centerlines?
                                Bret MacKie

                                Glenn, thanks for the reply.  I was not aware that you had to deselect the drawing view to disable the automatic centerline, this seems like a workaround for a buggy feature.(?) The step that you recommend seems counterintuitive since there exists a radio button to enable, disable this feature, (Auto Insert, Select View)  and it remains unchecked.  Does this button do anything?

                                This new info might be helpful if I can remember to deselect the drawing view before using the tool. Alas, however, I am a tad forgetful. And thus there is still the risk that if I forget to deselect the view and try to use the tool, my drawing could suddenly become trashed beyond repair. This doesn't seem like an acceptable level of risk user should have to face as a consequence for forgetting to use a workaround for a buggy feature.

                            • Re: how to prevent autoinsert centerlines?
                              Bret MacKie

                              I am under the impression that this is not a planned behavior, and reiterate my example of the radio button that turns the behavior on and off.  The radio button serves no purpose if what you say is true, that this is "planned behavior".

                              If we look at the available Solidworks documentation that details working with the tool, it says nothing about pre-selection of views to activate automated centerline behavior.  I have attached the text from the pertinent  "Help"  section below. Note that it not only fails to mention preselection, but explicitly allows for the user to drop centerlines manually after first choosing a face. (See " ** ")

                              Note that it is impossible to select an entity without selecting the view first.

                              ----------------------------------------

                              To insert centerlines manually:

                              In a drawing document, click Centerline, or click Insert > Annotations > Centerline.

                              The Centerline PropertyManager appears.

                              **You can select either the tool or an entity first.

                              Select one of the following:

                              Two edges (parallel or non-parallel)

                              Two sketch segments in a drawing view (except splines)

                              A face (cylindrical, conical, toroidal, or swept)

                              A view in the graphics area

                              A feature, component, or drawing view in the FeatureManager design tree

                              Click OK.

                              -----------------------------------------

                              Furthermore, if one needs to start a thread in the forum in order to discover how to avoid unwanted automatic behavior, then I might venture to say that the authors of the Help section have overlooked something.

                              Cheers

                                • Re: how to prevent autoinsert centerlines?
                                  Josh Brady

                                  Bret MacKie wrote:

                                   

                                  I am under the impression that this is not a planned behavior, and reiterate my example of the radio button that turns the behavior on and off. The radio button serves no purpose if what you say is true, that this is "planned behavior".

                                  If we look at the available Solidworks documentation that details working with the tool, it says nothing about pre-selection of views to activate automated centerline behavior. I have attached the text from the pertinent "Help" section below. Note that it not only fails to mention preselection, but explicitly allows for the user to drop centerlines manually after first choosing a face. (See " ** ")

                                  Note that it is impossible to select an entity without selecting the view first.

                                  ----------------------------------------

                                  To insert centerlines manually:

                                  In a drawing document, click Centerline, or click Insert > Annotations > Centerline.

                                  The Centerline PropertyManager appears.

                                  **You can select either the tool or an entity first.

                                  Select one of the following:

                                  Two edges (parallel or non-parallel)

                                  Two sketch segments in a drawing view (except splines)

                                  A face (cylindrical, conical, toroidal, or swept)

                                  A view in the graphics area

                                  A feature, component, or drawing view in the FeatureManager design tree

                                  Click OK.

                                  -----------------------------------------

                                  Furthermore, if one needs to start a thread in the forum in order to discover how to avoid unwanted automatic behavior, then I might venture to say that the authors of the Help section have overlooked something.

                                  Cheers

                                  What release/SP are you using?  I don't remember when they added that checkbox to the interface... Back in 2010 when this thread was started it wasn't there.

                                   

                                  I'm running 2017 SP5.0 right now.  The checkbox seems to work as it should:

                                   

                                  [Nothing selected, run centerline tool]

                                  Box is un-checked.  Clicking a view does nothing, clicking geometry works as expected.

                                  Checking box allows me to select a view for auto-insert.  However, it seems to not auto-select big views of assemblies?

                                  [View selected, run tool]

                                  Same as above... Centerlines are not automatically applied to the view that was selected when the tool was run.

                                   

                                  Also note that killing the thing and restarting may not be necessary unless you already had a lot of centerlines on the view that you want to keep.  You can use the selection filter for centerlines and box-select select the whole thing and delete.

                                    • Re: how to prevent autoinsert centerlines?
                                      Bret MacKie

                                      I am using 2018 SP2. The Auto Insert [Select View] radio button is in 2017 and 2018, not sure about 16 or before.

                                      What you are describing is normal behavior. The "bug" happens only on occasion, although with the drawing I was recently working on, I was able to replicate the behavior repeatedly and recorded a video to send to SW RX.

                                      Normal workflow: View is selected or not selected, select centerline tool, select one side of cross-sectioned bore, select the other side, centerline is created.

                                      Workflow to replicate problem: View is selected, ( I did notice that this only happens when the view is preselected) select centerlines tool, select one side of two of a cross-sectioned bore, system locks up for several minutes, then we have 10,000 centerlines in that view.

                                      Thanks for the advice, I will have to check out the selection filter, I've never played with it before.