6 Replies Latest reply on Mar 29, 2010 8:27 AM by Mike Sveda

    Tasks only work on my computer

    Derek Bessette

      I have setup and tested print and convert tasks using the admin tool on my computer.  They work fine on my computer but do not work on other computers.  I have run the task host configuration on the computers in question.

       

      Do I need to do anything other than this to get tasks to run on other computers?

      When I installed the convert and print tasks it automatically installs the required add-ins.  Where are these installed.  Are they local on my machine or do they get installed on the server?

        • Re: Tasks only work on my computer

          Do these other computers have SolidWorks installed? Print and Convert tasks both require SolidWorks to run the task.

           

          The addin dlls are loaded on each client computer when Enterprise is loaded. Not sure the exact location. It is somewhere under Documents and Settings.

          • Re: Tasks only work on my computer
            Mike Ramsey
            I have task that creates a PDF everytime a drawing moves to a new state. It's pretty flaky and from what my VAR is telling me the task add-in is a good idea poorly executed. I get a lot of failed to write PDF messages.
              • Re: Tasks only work on my computer
                Tim Webb

                If this issue isn't resolved yet, I will throw my research into the pool.

                 

                *edit* Derek *edit* it sounds like your setup is 99% complete and you have been experiencing the same problem I was banging my head on the wall with. Tried messing with/uninstalling firewalls, port sniffers, installing/uninstalling/installing SolidWorks and every flavor of EPDM, 32-bit vs. 64-bit, exact SP matches, etc. to no avail.

                 

                This fix, fixed our setup:

                If any other computers are setup for Task Host Configuration then for the server to actually use those computers for the Task Host, a user must be actively logged into the vault on that computer.

                 

                HTH