10 Replies Latest reply on May 23, 2018 2:12 AM by murat oz

    File Property "Description" does not show in Windows Explorer column

      Setup: SWX 2010 SP02, WIN XP64

      Problem: Column header in Windows Explorer should show the custom  properties of the file but it doesn't.

      The information is in the file but not being read by Windows Explorer.
        • Re: File Property "Description" does not show in Windows Explorer column
          Alessandro Frattini

          For me works fine.

          Try to add a column, because this description is the 'summary description' and not the SW file description property.

          • Re: File Property "Description" does not show in Windows Explorer column
            Jason Weatherall

            Lawrence did Alessandro's comments help you at all?


            I am having the same problem and find it frustrating as we use part #'s as the file name and rely on the description for identification.



            I have two description column options both turned on and they do not reference the SW description.  Would like to know if you found a solution for this.










            • Re: File Property "Description" does not show in Windows Explorer column
              Luiz Demenicis

              Hi, it works fine for me in both XP and W7.


              Try going to SW options/general and set which ever custom property you want to be considered "description" by windows explorer.


              In my case I'm frustrated because SW doesn't offer the possibility of using "title" as file description (only custom props),  so I have a macro running all the time to set a property called "description" = "summary title", so I can identify my parts when inside the assemblies (otherwise I'd only see numbers, my file names are serial number as it should).

              This is a bit rubish from solidworks but at least i found a workround via macro.



                • Re: File Property "Description" does not show in Windows Explorer column
                  murat oz

                  One of the main causes of the Description field issue is that the sldpropertyhandler.dll was not properly registered on the PC. We have had some trouble getting this to register properly due to insufficient permissions. We found that by running the command prompt as the administrator was the most effective way to resolve the issue.

                  1. First, locate where you have the sldpropertyhandler.dll is stored on your computer. To do this, open Windows Explorer and navigate to your SOLIDWORKS installation directory. The default location is C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS). Once you find sldpropertyhandler.dll, take note of the path to this file.

                  2. Open a command prompt by going to Start > Run > type cmd. Right click on cmd.exe and pick Run as Administrator.


                  3. In the command prompt, type in the following based on your SOLIDWORKS installation folder location as noted above:

                  regsvr32 “C:\Program Files\SOLIDWORKS Corp\SolidWorks\sldpropertyhandler.dll”

                  Hit the Enter key on your keyboard.

                  4. Make sure that you get the registration was successful message.

                  Run SOLIDWORKS and verify that the issue is resolved.