AnsweredAssumed Answered

SolidWorks database missing

Question asked by 1-8NPNVX on Jan 14, 2010
Latest reply on Aug 31, 2013 by Loren Nebeker

Hi,

I'm using SW2010 SP0 Premium x64 with motion and cosmos on a Dell Precision 690 with dual 4 core Xeon X5355 2.66GHz CPUs and 8GB ram

 

I've had toolbox database problems ever since upgrading one of the 2007 service packs.  SW would always say it couldn't find the toolbox database when pulling out a screw, etc, but it would always still work.

 

Since upgrading to 2010 SP0, it has gotten worse - every time I load SW, a message comes up that is titled FeatureWorks and reads: SolidWorks database is missing. Complete functionality will not be available.  No toolbox functions work, and the hole feature does not work - other things might not work but I haven't gotten any further.  The hole feature error message reads that it cannot find swbrowser.mdb in the C:\SolidWorks Data\lang\english\ folder, which is empty, and windows search can't find the file either.

 

I completely un-installed all earlier installations that showed up in Add/Remove Programs, and the current one, and did a clean install and the problem is still there.

 

Under System Options - Hole Wizard/Toolbox, the path is correct (C:\SolidWorks Data\), but if I hit Configure, an error pops up labeled Toolbox that reads: The Toolbox database file was not found in this folder: C:\SolidWorks Data\lang\english\.  That folder is indeed empty, but the rest of the toolbox files seem to be in the SolidWorks Data folder.  Maybe I just need a copy of swbrowser.mdb to throw in the right folder but don't know where to get it - it is not on the installation disk, so it must be decompressed or created during installation.

 

I have tried the repair option in the installation manager, but that does not change anything.

 

I have tried using the installation manager to uninstall Featureworks and Toolbox, then re-install, but it won't let me re-install toolbox because it can't find toolbox folder:

"The installed Toolbox folder cannot be found: C:\SolidWorks Data\.

Make sure you have access to this directory.

SolidWorks installation or upgrade will fail if Toolbox is not present in  this folder.

To resolve this issue, repair the existing installation or select a different  Toolbox option.

This condition must be resolved before you can continue."

The folder is there, I have access, I ran the repair option, and it will not allow me to change the toolbox location... so I had to do an uninstall and re-install yet again... with the same messed up database issues as the result.

 

I don't know if this is connected, but ever since SW2007 SP?, any upgrade or installation fails at SW Explorer and now SW desktop search also fails.  I do not care about those features, so I just don't install them.

 

The only thing I have not tried is using the licence migration tool to completely get all SW residue off this computer before doing another clean install.

 

Can anyone help me?  I am getting very aggravated and I am losing days of work. 

 

Thanks,

Steve

Outcomes