4 Replies Latest reply: Jan 19, 2010 8:37 AM by Chad Schmidt

    2010 SP1 installation does not work with Sophos

      Dispite the webpage http://www.solidworks.com/sw/support/AntiVirus_SW.html which clearly states

      "For the applications listed below, you do not have to turn off or disable Anti-Virus (AV) during installation. These applications have been tested for the current supported version(s) of SolidWorks."

      Sophos 7.6.x does NOT work with the SP1.0 installer on my system.

       

      I have a brand new Dell Optiplex 760 running XP SP3.

      I put in the 2010 DVD and it offered to download and install SP1 for me. I thought I might as well go straight to SP1, so I chose that option. The files downloaded and verified but as soon as I clicked on the 'Install Now' button, the install manager quit. It just disappeared with no error message or dialog box. I tried again with the same result. I tried manually downloading the files they all verified OK too, but the installer still quit. After 3 failed attempts, I resorted to installing SP0 from the DVD and that went without incident.

      I then tried to upgrade SP0 to SP1, same thing. I deleted the downloaded files and redownloaded them at least 6 times in the last two days, every time the installer just quit with no warning.

       

      My VAR said to disable the AV software, but I don't have permission to do that. I am a local admin on my machine, but the AV software is controlled by a super-group. He showed me a way to disable it by stopping each process and then when I ran the installer, guess what? It worked.

       

      Sophos is listed as passing all the tests and in bold type the web page says you do not have to disable it. It even works to install SP0 with the AV still running but not for SP1, so the only conclusion I can draw is that there is a problem in the installer for SP1 (and also for SP2 EV - I tried).


      Either the installer needs to be fixed, or the web page stating that it does not need to be disabled needs to be changed.