1-OFQX2G

(Fixed) Antialiasing on certain Quadros does not work (SPR469994)

Discussion created by 1-OFQX2G on Jan 6, 2010
Latest reply on May 21, 2020 by Dave Laban

Well, I got a new machine last year with an expensive Quadro FX3700 just to see that with SW2009/2010 I can't benefit from the hardwares antialiasing capabilities. All I could do was enabling line antialiasing from inside Solidworks but even then the result was medicore in general and useless in wireframe mode where the lines remained fully jagged. After some research the admin guy pointed me to some threads in this forum where the problem was discussed and where I found the spr number and the hint that this is related to the use of opengl FBOs.

 

 

Seeing that even with the final SW09 Sp5 the problem was not fixed I finally decided to debug and fix the problem myself and I would like to share the solution with you. After applying the fix you will be able to enable forced full scene antialiasing from within the nvidia control panel and it will actually work!

 

I've tested it only with the 32bit version of SW09 Sp5 on Windows XP but I think that it will work with other SW / OS combinatons. If it does not give me a note and I will try to help!

 

Instructions for the fix:

1) Download this command line hex manipulator http://lilith.tec-man.com/binmay/files/binmay.exe

 

2) Download the zip file in the attachment of this post

 

3) Copy the batch files you find inside the zip and binmay.exe into the "Solidworks" subdirectory of your Solidworks install directory (e.g. C:\Program Files\SolidWorks Corp\SolidWorks\". Make sure that the file sldrglu.dll is inside the directory!

 

4) Make sure that solidworks is not running and run the FixFSAA.bat to apply the fix

 

5) In case you want to undo the fix run UnfixFSAA.bat and you are back to the original state

 

In the Nvidia Control Panel

- choose "Manage 3D settings" -> "Programm Settings"

- uncheck "Show only programs found on this computer"

- select in the dropdown box the programm "dassault systemes solidworks"

- set "Antialisaing - Mode" to "Override any application setting" and "Antialiasing - Setting" to the factor you want

- apply and CLOSE (!!!) the control panel before starting Solidworks

 

In the solidworks settings:

- goto "System Options" -> "Display/Selection", uncheck "Anti-alias edges/sketches"

 

Please drop me a note if it works and which Windows and Solidworks version you used.

Hope you enjoy it!

Attachments

Outcomes