AnsweredAssumed Answered

Problem with Exploded Line Sketch...

Question asked by David Massner on Dec 28, 2009
Latest reply on Dec 29, 2009 by Jeremy Mortl

I'm using SolidWorks 2010 SP1.0 now, and this is the first time I've ever had trouble with this feature. Here is what's happening:

 

I have a part with three pins on it that are concentrically mated to another part with three sockets. When I go to draw a routing line between the pins and sockets, only one of the pin-socket combinations will work. When I try to do the other two, SolidWorks makes a jog in the line and tries to add a plane, then tells me that the geometry is overdefined or cannot be solved. If I delete the plane, all is well, but I still have that stupid little jog in the sketch (not to mention, it is extremely time consuming to do this over and over). It will do this if "Along XYZ" is unchecked. And yes, the arrows are facing the right direction for the line to be completed. Any thoughts? I even tried rebooting my computer, since that has seemed to cure random problems in SolidWorks before... I've attached a few pics to help you visualize what I'm talking about.

Attachments

Outcomes