5 Replies Latest reply on Mar 4, 2010 9:06 AM by Bill McEachern

    Update Components Doesn't

    Samuel Schweighart

      Hi all,

       

      Does anyone have the problem where you delete a body from a part (that is in an assembly), but the body doesn't delete from the simulation.   I select update components, but that doesn't remove it. I  have to create a NEW study, and then re-create the constraints.  Any ideas?  (I could exclude the missing body from the study, but that seems to make the simulation unhappy, and they fail.)  I've also tried saving, closing, opening, etc.

       

      Sam

       

      SW2010 SP1.0 Win XP64

        • Re: Update Components Doesn't
          Samuel Schweighart

          “Yes, it's a bug that has been reported in SPR 515399 - "Deletion of a body from a multi-body part is not reflected/updated in the feature tree under the Simulation tab" - you will be notified when it has been resolved.

           

          Workaround is to create a new study and copy loads/restraints, etc, from the old study”

            • Re: Update Components Doesn't
              Brent Toavs
              FYI, I have found that renaming any of the bodies in the SWX feature manager will cause an update to the bodies shown in the Similuation study tree.  This was in a Linear Static study on a weldment, so the name change was done in the 'Cut List' on SWX.  No idea why that works but its simpler than copying a whole study every time a body is added or removed from the model.
            • Re: Update Components Doesn't

              Hello Samuel,

               

              A quicker way to have it update is to "Duplicate" the study.  SW does all the work of copying constraints for you, and you get a fresh list of parts.  I have had to do this many times when I add a part to an assembly after creating the simulation study.

               

              Simply right-click on the study tab that's not updating, select "duplicate" and give it a slightly different name.  After you are satisfied that the study works like it should, you can delete the other one, since it is out of date, or keep it around for historical reasons.

               

              David

              SW 2009 SP3.0

                • Re: Update Components Doesn't
                  Matt Medford

                  I've had a similar issue when replacing a part in an assembly that I'm running a study on.  It's an identical part with a slight feature change that doesn't change any of the interfaces or load locations. I replace the component in the model, then go to the study and click on "Replace All Components" but the name doesn't change in the component tree.  Just for kicks I went ahead and solved the study anyway, and I got the same results as the original study before I swapped in the new component.  But if I make the swap, click on update all components, save the file, close the file, open the file, then go back to the study - the name changes in the component tree, and I get results consistent with the swapped component when I solve.

                   

                  It's annoying, but it works.

                    • Re: Update Components Doesn't
                      Bill McEachern
                      In shells it can become slightly more problematic. I usually end making a new study (not duplicating as this tends to reproduce the issue on occaission) and dragging/dropping the existing items into it and then it seems to work. It is pretty easy to work around so I don't let it bug me anymore. The no work around issues are the ones to be concerned about in my humble opinion.