AnsweredAssumed Answered

Enterprise 2010 and IEdmAddin5

Question asked by 1-MLLSM2 on Nov 9, 2009
Latest reply on Nov 18, 2009 by 1-A5CHD1

Hi folks,

 

so I'm new here and new to the whole Enterprise thing, but I hope that we will have a good time together.

 

I had a question earlier about the GetBOM API, but my colleague asked that one for me. Now I'm here myself.

 

So the problem is:

We upgraded to Enterprise 2010 and now my addins aren't working anymore. When I want to add the .dll I get an error message saying "this dll does not implement the IEdmAddin5 interface".

But of course it does, I wrote

     Implements EdmLib.IEdmAddIn5

in my code. Had to use it for the 2009 version as well. But now it's not working anymore.

When I tried to figure out what could cause this, I looked at the Interop.EdmLib.dll. And I saw that it is version 5.14 in my VB project reference, but the created one has version 5.13 (properties of the file). Should be the same I think, maybe it has something to do with it, I don't know.

 

Anyone else ran into this problem?

 

Any help is very appreciated, thx,

Tobias

Outcomes