29 Replies Latest reply on Feb 3, 2012 6:28 AM by Brian Hoerner

    Convert Entities Problems

      Has anyone else had issues with convert entities with Solidworks 2010?  Many times whenever I convert entities in a sketch Solidworks will freeze up and crash.  I upgraded to 2010 SP 0.0 yesterday, but the problem is still persisting.  This can be in really simple sketches and really simple parts, and are the types of things that I routinely did in earlier versions.  I recently got a new work computer and am running Vista 64, but I also had the same problem on my home laptop with vista 32.  I never really used 2010 on my old machine with XP, and one of my coworkers who is still on XP and running 2010 pre-release hasn't really experienced the problem.  So it seems that this is either a Solidworks 2010 issue or a Vista issue.  If anyone else has experienced this I'd love to know if they've come up with any workarounds.

       

      My specs are:

      Intel i7 950

      6 GB Ram

      Quadro FX 1800

       

      Windows Vista Business 64-bit

      Solidworks 2010 SP 0.0

       

      As I said, I've experienced the problem on 2 different computers and the only common thing between them is Vista and 2010, and I never experienced it in Solidworks until I started using 2010, so I don't think there are any hardware issues.  Any insight would be greatly appreciated.

        • Re: Convert Entities Problems
          Kelvin Lamport
          Were the graphics drivers updated after SW2010 was installed?
          • Re: Convert Entities Problems
            Dave Solly

            I'm having this problem also, except its everytime I try to convert entities...

            Happens on newly created parts (with only one or two features), and existing parts taken over from 2010.

             

            Machine

            HP 8710W Laptop, with Nvidia Quadro 1600M graphics and 3Gb ram.

            Running Vista Business 32bit

             

            Would appreciate any help to rectify the problem, will install the latest approved drives for the GFX card tonight and see how that goes

              • Re: Convert Entities Problems
                Jerry Steiger

                Dave,

                 

                You should check to see what driver is recommended for the HP 8710W, not just for the Quadro 1600M. The latest and greatest for the 1600M may not be the best choice for the 8710W. This seems to be especially true for Dell machines, but could very well be true for HP machines as well.

                 

                Jerry Steiger

                  • Re: Convert Entities Problems
                    Dave Solly

                    thanks for the reply Jerry,

                     

                    I've downloaded the driver, which is several steps back from my current one.

                    Will run driversweeper to remove the later version driver completely from my system, then install the older on and see if it makes any improvement

                      • Re: Convert Entities Problems
                        Dave Solly

                        Ok, I have downgraded my graphics drivers 2 steps back to the Solidworks Approved Driver for SW2010, problem still exists with the same regularity it had previously.

                         

                        I normally keep my laptop loaded up with the latest addition of driver (generally ignoring the solidwork approved GFX drivers) as I have had no graphics related issues before.

                        Problem does not exist in SW2009, fortunately most of my files are still in 2009 format.

                         

                        Are the only people having this issue on Vista or Win7 or is this happening on XP as well

                          • Re: Convert Entities Problems
                            Phil Marra

                            My drivers are all updated and Im still running XP-64 here. Im now seeing problems with assy configs too. No matter how they are saved when I reopen them parts are showing that were not when saved............this release is just a huge dissappointment.

                              • Re: Convert Entities Problems
                                Dave Solly

                                I'd have to agree Phil,

                                Generally I've always run with pre-release, then fully changed over at SP0.0, but for some reason it didn't feel right this time, I'm glad I didn't.

                                 

                                Looking through the error logs on the computer I'm seeing this error  - Faulting application solidworks.exe, faulting module pworks.dll.

                                is this the same error that you are getting?

                                error.jpg

                      • Re: Convert Entities Problems
                        Dave Solly

                        I have a solution to the problem, for anyone else that is suffering it, for the first time using the support provided by our VAR has proven helpful (normally a waste of time

                         

                        Solutions as follows

                        This issue may occur if a user has multiple installations of SolidWorks on the PC, and does not follow best practices for installation locations. (For exmaple, browse to %Program Files%\Solidworks Corp to see if “SolidWorks”, “SolidWork (2)”, “SolidWorks (3)”, etc. exist.)

                        The root cause of the issue is related to .NET Framework which is integrated into Vista. Please see the attached ZIP file containing an EXE which will fix this .NET problem. To apply this EXE, please perform the following steps:

                        1. Download the attached ungen.zip file
                        2. Extract the EXE to a location which can easily be navigated to from a command prompt
                        3. Open a command prompt as an administrator (Start -> All programs -> Accessories – right click on Command Prompt and choose “Run as administrator”
                        4. Use the “cd” command to change to the directory where the EXE was extracted to. Example: cd "C:\ungen" (if the EXE is extracted to C:\ungen)
                        5. Type “ungen.exe” and press Enter, then wait for the process to finish
                        6. When it is complete, start SolidWorks and test to see if the crash is resolved.

                          • Re: Convert Entities Problems

                            To all concerned:

                             

                            This convert entities problem is a major PAIN.  It has caused me all kinds of down time.  I have made sure that my drivers are correct.  Infact one of my tech helpers from Mcad uses the exact same system I do, and we even went so far as to compare the proper drivers for our video cards.   I have done diognostics, and everything else that my technical people have asked me to do.  It still chashes on the simplest things.  One time the entities converted, and then as I revolved the model with a mouse, it crashed.  Sometimes it is when I try to make a featrue after a converted entity, like extruding a cut or a boss.

                             

                            I am not as smart about computers as most of the people are in these forums.  So this last fix was sort of like reading a windows error message.  In otherwords I did not understand it.

                             

                            I use XP 32 bit. I am using 2010 sp1. 

                             

                            I also use other software that takes DXF files converted from Solid works to a plotter cutting machine.  I do not want to change my operating system.  That would cause even more down time.  I have asked my Tech support team to look at this Forum site and help me out with the technical information.

                             

                            It seems very strange that this problem occures over these different opperation systems.  It also seems that there is a net framework fix from Microsoft, but I am not savy enough to understant the last email that deals with the problem, nor do I think we are each operating off the same system.

                             

                            If it were not for some very nice featrues that 2010 has that I like I would go back to 2009 sp3 when I was having no problems.  However now all the converted files would not work on the older system.  I feel helpless.   

                              • Re: Convert Entities Problems
                                Dave Solly

                                Hi Jack,

                                 

                                The fix that I posted is specific to Vista, the way Vista handles the .net framework is different to XP and apparently this causes the problem.

                                Obviously this is not the case. Have you tried Service Pack 2.0?

                                 

                                Do you still have older copies of solidworks installed on your machine?

                                if you browse (in explorer) to C:/Program Files/Solidworks Corp

                                what does your directories in there look like? do you have multiple copies installed (directory name followed by (2) or higher)

                                apparently this can cause some issues.

                                If you do (this will cost you a bit of time) I'd suggest that you uninstall ALL copies of Solidworks including 2010 and re-install a fresh copy.

                                 

                                With regard to the OS, to be honest, this might be a good time to consider it, Windows 7 is a fantastic OS and I think I read somewhere that Solidworks will be stopping support of XP when 2011 comes out.


                                A fresh install (OS and Programs) is alway nice to work on... so quick and uncluttered

                                  • Re: Convert Entities Problems

                                    Thanks Dave for trying.

                                     

                                    Service pack 2 is installed, There are no old copies of solid works.

                                     

                                    Now  the problem seems to have shifted.  I am getting a crash durring all kinds of simple sketch scenarios.  Adding a feature, mirroring sketch entities.

                                     

                                    I am so gun shy that I save after every sketch, or after each featrue.  sometimes it fails then too.  Am I getting frustrated,

                                     

                                    Honestly there has to be something that I did, and I can not figure it out.  No one else out there seems to be having these issues.

                                     

                                    I will muddle along for a couple of days, but then I really need to get some design work done and I end up here in the forum looking for help again.

                                     

                                    Well thanks anyways.  I may have to purchase a new computer if sp3 does not fix this.

                                     

                                    Jack

                                      • Re: Convert Entities Problems

                                        to all concerned and especially to Dave

                                         

                                        Kurt Is my tec peroson at MCAD.  He helped me out on this,
                                        We thought that Dave may be right, and that there were some files left over from the install that were mucking things up, so we removed everything solid works, 
                                        I have about 3 hours work on the same part that was giving me fits yesterday with a fresh squeeky clean reinstall with no vestages of other solid works programs. 
                                        It is working better.  However it did crash 3 times in 3 hours.  This is 2010 SP 0  right off the disk. 
                                        A fresh D frag, and Kurt even took control of my computer, and removed all old files. 
                                        The Anti virus was off.  
                                        Now does anyone have any recomendations. 
                                        I await a reply, and I have sent this same letter into the forum.  There seems to be some folks there that may be able to help. 
                                          • Re: Convert Entities Problems

                                            For those interested;

                                             

                                            We installed sp 2 and I have not had any problems with it crashing since.  More than 2.5 hours of work without a crash.  this is very good.

                                             

                                            I only wish I had done this a month ago.  However sometimes one has to get frustrated enough to take the time, and exhaust the possible fixes.

                                             

                                            I will never again load a new version of solid works  without deleting all possible files from the regestry, and my computer.

                                             

                                            I have a strong inclination to let the sp o program go for a while until it is at lease sp2 or 3.

                                             

                                            Let someone else get the bugs worked out.    Obviously sp0 was not friendly on my system.

                                             

                                            Well thanks everyone for helping.

                                             

                                            Jack

                                    • Re: Convert Entities Problems
                                      Jason Raak

                                      i am seeing this same problem using solidworks 2010 sp 2.0 on a vista 64bit machine.  i just ran the ungen.exe so i am hoping this fixes the problem.  i will keep everyone posted.

                                       

                                      thanks for posting this fix dave!

                                      • Re: Convert Entities Problems
                                        Jason Raak

                                        sooooo, an update from our end.  the ungen.exe trick did not work for us.  after some time on the phone with our var, we decided to rename the existing solidworks registry under HKEY_CURRENT_USER > Software to SolidWorks_old.  we then restarted SolidWorks so it would create a brand new SolidWorks registry and we have not crashed since (1 day) which is a HUGE accomplishment from what we were experiencing.

                                         

                                        when we installed solidworks 2010 i did a clean installed but reapplied the user settings once it was installed.  i will keep you informed if they find anything wrong with our old registry.

                                      • Re: Convert Entities Problems
                                        The only way to convert sketch entities in 2010 is with SP2.1 or higher.  The 2.1 patch does not remove the worthless new dialog box from the  convert operation and it will freeze for a very long time but it won't completely crash.
                                          • Re: Convert Entities Problems
                                            Ryan Laplante

                                            Wow since this is my primary mode of drawing is to create a master sketch and planes and then convert the sketches to derived sketches that are used for extrudes, I do have SP2.1 but I have primarily been doing modifications with 2010 and have not built anything with it, it was installed on Monday the 1st

                                            Will respond when I start modeling things tomorrow...

                                              • Re: Convert Entities Problems
                                                Bill Reuss

                                                I've seen similar instability with Convert Entities - on both my machine and at least one of my co-workers.  You can keep your system from crashing after you use Convert Entities by canceling the command - click the red X in the new dialog box or the confirmation corner.  If I hit the green check mark in either location my machine will lock up 90% of the time.  HTH.

                                                 

                                                   Bill

                                                  • Re: Convert Entities Problems
                                                    Bruce Fisher
                                                    I've been running SW2010 SP 2.1 for a few weeks now, but hadn't noticed the convert problem till another user showed me this morning.  We're running XP 32 bit, and yes, we still have SW 2009 installed.  How can you afford not to have previous versions when you still have projects that were built in those versions?  This is an excellent example of how SolidWorks policy of not allowing you to save to previous versions holds the user, and the user's data, hostage.  Unacceptable.
                                              • Re: Convert Entities Problems
                                                Brian Hoerner

                                                So has anything ever been verified to fix this?  the fix noted below does not work for us, we do not install into Programs directory anyway, but...

                                                 

                                                I have only one user with this problem, gave him a newer workstation with a brand new fresh all install, says he still has the issue, he is on SW2010 SP4.0, so will see about updating him to 5.0, though i think that will not do anything either.  removed his registry settings but says he still has the issue, I am going to try and duplicate it today on his workstation, though he tends to be the trouble child anyway most of the time, doesn't make sense that he is still haveing this issue

                                                 

                                                We are currently not on maintenance because of not seeing value moving into SW2012...another story though ,  any newer thoughts or suggestions?

                                                 

                                                Thanks folks,

                                                Brian