AnsweredAssumed Answered

Dispatch\Administrate Actions.....Set Card Variables not working?

Question asked by Ian Shoultz on Dec 15, 2020
Latest reply on Dec 16, 2020 by Ian Shoultz

Good evening all,

   I was wondering if anyone could point me to the errors in my variables? I am trying to create a dispatch that will copy variables out of a part/asm file data card, create a word doc from a template, and paste those variables to the new word doc. 

Here's a screenshot of what a blank one should beExample

 

I had it working earlier this afternoon, but of course I didn't save the acn file and something happened (I tried to combine them into 1 dispatch). Now I recreated what I had earlier (I thought), but it won't copy the variables like it was doing before. I'm guessing that my variables aren't mapped correctly.

Here is a screenshot of what I have. I'm not good at writing these, but was able to string together this from reading these forums.

Step one: Select the Solidworks files and create shipping tag in PDM. (I tried to have the files checked in automatically but I couldn't get it to work)

Create Shipping Tag

This should copy the part number from the data card of the CAD, but it isn't working. It then should name the new docx. file after the one selected to create it.

Missing Part Number Variable to name the new file

 Step 2: RMB on the CAD files, Update the properties from the CAD data card to the .docx data card.

Edit Action dialog box

Note: There were quite a few more Set card variables Commands but I removed a majority of them just trying to get one to work.

Missing copied properties

 

I'm sure that this is something simple that I'm overlooking, but I've racked my brain all day trying to get back to where I was (NOTE: Save copies outside the vault?) If anyone could point me in the right direction, I'd sure appreciate it!

 

Thanks in advance!!!

Outcomes