AnsweredAssumed Answered

Struggling to deploy my Add-In to other computers

Question asked by Jared Ticotin on Dec 9, 2020
Latest reply on Dec 11, 2020 by Amen Allah Jlili

I created my add in and it works on my computer. I tested it on another computer and at one point it was working. Then I updated the add-in to show an icon in the add-in list and the update wasn't showing on the other computer (though the add-in still seemed to be working at that point, it just didn't get the update). So I went in and deleted all registry keys with that GUID and then reregistered the dll. Now the add-in doesn't seem to want to activate...

I realize I should have probably done a system restore point before that (oops).

 

Right now when I open solidworks on the other computer, it does show the addin. when I go to the add-ins list and I can select it but it doesn't activate. I don't get an error message or anything. The addin is in the list, I'll check it and click "ok" and it doesn't activate and when I look at the addin list again, it shows as being unchecked.

 

Here's what I tried:

-I compared the registry on my computer against the other and made sure they were the same

-I unregistered the dll and reregistered (using a batch file)

-I tried setting up an installation file per Creating installer for SOLIDWORKS add-in with Visual Studio Installer (VSI) - YouTube 

-I released again but with a new assembly version number and then ran my batch file again

-I registered the dll with a tlb file

 

Everything I tried has the same result. The registry looks correct as far as I can tell (at least everything with the same GUID) but it just won't activate the add-in. I'm releasing the dll as x64 to 64-bit Windows 10 computers. Does the add-in need to be COM visible? I never set it up that way and somehow it was working at one point (and currently still works on my computer). I'm registering with this command:

RegAsm.exe "C:\Program Files\SolidWorks Corp\SolidWorks\api\redist\MyAddin.dll" /codebase

When I unregister, I just use the /U option instead of /codebase. Also I did try adding the /tlb but that didn't help.

 

Any suggestions? 

Outcomes