John Reinhard

Unknown error when accessing ~$ file

Discussion created by John Reinhard on Nov 20, 2020

As a school with a lab we have to use a network server for user files.  If you have a similar setup this may be of interest to you.   For the past couple of months we had users that would randomly get an error opening parts and assemblies.  The error would say something like-- Unknown error occurred.... accessing ~$yourpartfile.sldprt.  The problem was finally solved, and I hope this might help another school.  Our server administrator solved it and sent this out--

"It turns out one of the [recently upgraded] production Samba servers... was trying to record the hidden lock files using extended attributes.  This was because a default value for "store dos attributes" was changed from no to yes [during the upgrade].  Linux NFS does not currently support storing extended attributes, so Samba was returning failure for the hide file request, and therefore Solidworks was refusing to move forward in opening the file." 

So be careful when upgrading your samba servers if these servers read and write files from an NFS server.

Outcomes