Carlos Orero

Help fixing references: working with "configurations" to "parts"

Discussion created by Carlos Orero on Nov 16, 2020
Latest reply on Nov 18, 2020 by Heiko Sohnholz

Hello, everyone.

We are in the process to migrate from working with PDM standard to working with the 3DEXPERIENCE.

 

For those not knowing, working with toolbox in the 3DEXPERIENCE requires that all the hardware files are created in advance by an admin and then uploaded to be available to all the designers. In my case, I have configured our toolbox and created more than 1500 parts (the minimum I've considered necessary). I don't like this approach at all, but it is what the official help says. Ok.

 

"In library manager approach, the toolbox library manager sets the toolbox database and files before the designers can use them. When designers use toolbox part files, the files are already saved into 3DEXPERIENCE. You can follow the below procedure to set and configure the toolbox." https://help.3ds.com/2021x/english/dsdoc/swsadminmap/sws-t-toolbox-library.htm?contextscope=cloud 

 

 

In the 3DEXPERIENCE environment, we have to work with the option "create parts". But in PDM standard we were using the option "create configurations". Furthermore, I had the toolbox installed in our server where PDM standard was installed and I had to move the toolbox folder to a shared location prior to creating and uploading all the files.

 

Toolbox - User settings - files

 

Now I'm facing a HUGE problem. When opening any old assembly the toolbox parts are not properly opened since the assembly tries to load configurations of a master file instead of loading the specific file.

 

Is there any way to fix the toolbox references automatically??? I don't want to insert again all the hardware in an exhausting and frustrating way (I mean manually).

 

Kind regards.

Outcomes