AnsweredAssumed Answered

PDM Standard Workflow State - Can't Remove User

Question asked by Daen Hendrickson on Oct 30, 2020
Latest reply on Oct 30, 2020 by Daen Hendrickson

I am using SW2019 SP5 with 2019 PDM Standard.

 

In setting up our PDM Standard Vault, we opted to pre-configure using the "Default" vault template. From there I have modified the workflow. Before setting up groups, there were just two users - the admin and myself. The "me" user profile had all permissions.

 

As I cycled through the modifications to the workflow states and transitions I eventually removed "me" as a user from all the states & transitions and replaced with the various groups. So now, all of the states and transitions only show groups and the Admin user in permissions... that is all but one. In the "Initial State" I can NOT delete "me" from the Permissions Name list.

 

Logged in as the Vault Admin, I can select "me" and click the remove button and my user is removed from the Permissions Name list. However, as soon as I re-enter the state Properties dialog the "me" user has returned to the Permissions Name box.

 

This only occurs with the "Initial State". I successfully removed "me" as an individual user from all other states and transitions.

 

Am I seeing a bug, a permissions issue? I get no warnings when I delete and the delete seems to be successful - until the next time you view the properties.

 

Having "me" as a single user is not affecting the workflow function since I am a member of the Vault Administrators group which has all permissions.

 

But I would like to clean up this odd bit of left-overs from the initial setup.

 

Thanks,

Daen

Outcomes