Tae Rugh

Issues Updating to Solidworks 2020

Discussion created by Tae Rugh on Oct 24, 2020
Latest reply on Oct 25, 2020 by Jim Riddell

So I messed up and accidentally deleted (or tried to delete) Solidworks 2019 from the file explorer. This resulted in a weird case where I have some really important files missing but the bulk of the program still installed. Then I tried to install Solidworks 2020 on top of that and everything is messed up. So here are the issues:

   - When I click the Windows start button and search for Solidworks, nothing shows up.

   - When I try and open a Solidworks file, I get this warning, but it still opens.

- When I try to create a new component, I get this

 

That's what I've noticed so far, but honestly there are probably a ton of other issues. I think the best thing to do would be to totally uninstall Solidworks and then try and reinstall it. But I'm even having trouble doing that:

   - When I go to "Apps and Features", Solidworks doesn't show up.

   - When I try and delete the remaining files in program files, I get this

   - I tried running the registry editor and uninstalling from there, but it didn't seem to do anything.

 

If you have any suggestions, please help me out! I really need to fix this soon. Thank you!

Outcomes