AnsweredAssumed Answered

Enhanced Graphics & Full Scene Anti-aliasing, Sketches NOT anti-aliased

Question asked by Justin Lee on Oct 5, 2020

Have seen a few questions about Full Scene Anti-Aliasing not working properly in SW2020.

 

Seems I've found the trigger & how to work around. This is not a FIX, per-se, just a work around.  Would be up to the VARs & DEVs to properly flag this as a bug & implement a genuine fix down the road.

 

The issue relates to the new Enhanced Graphics feature (which is ENABLED by default in SW2020).  When Enhanced Graphics is ON, Full Scene Anti-Aliasing has unexpected behaviors.  See Screenshots & annotation below

 

 

 

If you use Full Scene Anti-aliasing and prefer your sketches to be anti-aliased as well (which is the expected behavior for all previous versions of Solidworks) try DISABLING Enhanced Graphics (Tools > Options > Performance > Enhanced Graphics Performance).

Outcomes