AnsweredAssumed Answered

Solidworks splash screen disappears after "Loading Registry" - issue persists after full reinstall

Question asked by Chris Picone on Aug 31, 2020
Latest reply on Sep 17, 2020 by Rick Becker

After a computer crash that happened about a week ago, I've had a semi-persistent issue leaving me unable to launch Solidworks. When I open Solidworks, the splash screen gets to "Loading registry", pauses for several seconds, and then closes. No error message, doesn't hang, it just disappears and the process drops off the Task Manager. No crash report.

 

I have read several other threads and tried many different things to fix this issue. First thing I want to point out is that the issue is probably unrelated to network licensing. When I disconnect from our license server, the license check fails before the app would close, and I get the usual error message. When I borrow a license from the network and then disconnect, the app tells me about how much time I have left on the borrowed license before continuing (and then disappearing / crashing). So I am confident the issue is unrelated to licenses or network permissions or what have you.

 

Other things I have tried, that did not seem to work:
- Launching in Safe Mode (OpenGL and No Settings)
- Restarting Solidworks
- Restarting the computer
- Deleting (renaming) the registry data for Solidworks
- Uninstalling and reinstalling Solidworks
- "Repairing" the Solidworks installation
- Re-downloading and reinstalling Solidworks from new installer file.
- A full and complete uninstall, including all relevant registry files, C++ and .NET dependencies, per this guide: Complete Uninstall of SolidWorks 

- Most of this guide: SOLIDWORKS Crashes or Hangs on Splash Screen – Support Main 

 

Below are things that seemed to work for 1-2 days, but then the problem came back, so it is unclear if they did anything at all to help the issue or if I just got lucky:
- Complete uninstall per the above guide again, then running a Windows Update on some Windows files including .NET dependencies
- Disabling Switchable Graphics in BIOS
- Disabling .NET, restarting, running .NET Cleanup Tool, restarting, re-enabling .NET (reinstalling from Windows Update) (I'm not sure if this immediately worked) Steps here: Repairing Microsoft .NET Framework – Support Main 

 

All of the above solutions did not work a second time when the issue returned.

 

I'm really running low on options here. For a variety of reasons, reinstalling Windows on this computer isn't a good idea right now, and that's about the only thing left I can think of. All of the advice I have seen on this assumes the user doesn't recognize the app opening in the background, isn't connected to a license server, etc. and their advice hasn't helped me. I have no idea why this happens, or why it will come back after it is "fixed" by one of the extreme examples above.

Does anyone have any idea what could be going on?

Outcomes