AnsweredAssumed Answered

Coordinates system can't keep references (wrong transform)

Question asked by Edith Clerc on Jul 9, 2020
Latest reply on Jul 10, 2020 by Josh Brady

Hello,

 

I have an issue when I create coordinates systems. I and several colleagues have struggled upon this for 2 days and we still can't figure it out :

 

When I create or edit the system, the Coordinates System PropertyManager open (see picture). I select an origin, a reference for X, Y and Z. The I save with the "validate" button :

 

1

 

The problem is, if I edit this coordinate system again in the PropertyManager, the references that I setup the first time are not the same. Now there is a reference for Z and Y but the reference field for X is empty :

 

2

 

New coordinate system : I select on origin, a reference for X and Z, and I save.

When I reopen it, the reference for Z is still there, but the reference on X is empty and there is a reference on Y wich was generated by Solidworks !

 

Another try : I selected a reference for X and Z , and when I repoen it there is only the refernce for Z. 

I did it again, and when I reopen itthe three fields are empty. 

 

Sometimes, the coordinates system rotate when they "loose" one of the references.

 

 

I tried to use all kinds of references (axes, cylinders, points, sketches).

I tried to create the coordinates systems in the general assembly, in the subassemblies and it the parts.

 

Sometimes they keep their references, the bug seem to appear randomly.

 

This instability is causing me big troubles because  I use a plugin (SW2URDF) to export the assembly, and it relies on the coordinates system transforms. When I try to export an assembly, the coordinates systems have wrong RPY values (but XYZ values are correct).

Outcomes