AnsweredAssumed Answered

Solidworks API References

Question asked by Kyle Thomson on Jul 6, 2020
Latest reply on Jul 6, 2020 by Jim Sculley

Hi all,

 

      Last week my macros were running perfectly fine. However, this morning I went to run the exact same one and now am getting a compile error. It opens up the Solidworks references tool bar automatically through the error message. Looking closer I noticed that Microsoft office 16.0 Object Library and Microsoft Forms 2.0 object library are not in the directory anymore (like not even listed and no check boxes for them). I have tried closing Solidworks and reopening it, rebooting the entire computer. and talked to my companies IT department. So far none of these solutions have worked out. Does anyone have any suggestions for getting these back to get the code to run? I have attached my code mostly commented out so that it is just supposed to list the DIM's, open the part, and close the part. The first error seems to be encountered on the line Dim ExcelFile As System.String.

Outcomes