Dan Pihlaja

File did not save, and no error shown....and I didn't notice all day....

Discussion created by Dan Pihlaja on Jun 20, 2020
Latest reply on Jun 23, 2020 by Dan Pihlaja

Yes, I meant to create this as a discussion:

 

I just had an issue where I was attempting to save a model from Solidworks.  All day today, I was hitting the save button as I worked on it and did NOT receive an error message of any kind, so I didn't notice that it wasn't saving.  About 3 PM, I noticed that the file that I was trying to save wasn’t updating the time stamp on the “date modified” column in Windows explorer.  So I decided to try to close and reopen Solidworks.  When I hit the X to close it, it prompted me to save, which I said yes to, then simply did nothing.  It did not close.  And it did not update the date modified time stamp either.

 

So I decided to try a Save As and saved the file with a different name.  That worked, so I was able to close Solidworks.  However, when I opened Solidworks and tried to open the new file, it gave me an error message: "Solidworks encountered a problem in the file: blah blah blah.SLDPRT.  Contact your Solidworks support representative for help."

 

It was then that I noticed that the file that I created with the save as command was 0 kb in size.   This generally indicates a corruption in the file.

 

So this file got corrupted sometime after 5:08 PM on the 19th, which was the latest time stamp on the original file (which I THOUGHT I was saving all day today.....which is the 20th.).  Probably sometime after I opened it this morning.

 

I did confirm that I can open the original file and run a save as, so the original file is still good.  But all the work that I did today, didn’t save for some reason and was lost, unless somehow we can get that info from the 0 kb file (I doubt it).

 

I reboot every night, so the file was not left open overnight or anything like that.

 

Anyone else ever run into this?

Outcomes