AnsweredAssumed Answered

Can't edit properties in Assembly Visualization

Question asked by Ramzi Rebeiz on May 28, 2020
Latest reply on Jun 23, 2020 by Quentin Poupore

Hello,

My first question to the SW forums, patience greatly appreciated.

 

I'm having issues editing properties from within the assembly visualization (AV).

2018 SOLIDWORKS Help - Editing Property Values 

the above link is what I'm trying to follow, but the "Editing Noncalculated Properties" is not working for some reason.

 

For example I would like to use the AV to change all the descriptions of parts and assemblies.

I added the property "Description" to one of the parts in my test assembly, gave it a random description

 

 

Now back to the assembly. It shows up correctly in the AV

 

And it looks like I can edit it, but It does not retain it.

I double click, edit, hit enter, and it stays with the new description in the AV

 

but back in the part, it didn't change. it's still the original description

 

And then when i come back to the AV in the assembly, it jumped back to the original description

 

If I change the property in the AV, open the part and DON't open the configuration properties, then go back to the Assembly, the AV retains the new value. But, as soon as I open the configuration properties in the part, it will show the original not the new property, and the AV will revert back to the original.

 

 

I run into the same issue with any custom properties.

 

 

Even if i make a completely custom property in a part, it still won't let me change it (without changing back) from within the AV (see below with "test text" which i entered from withing the configuration properties in the part, and tried to change to "new text" from within the AV)

 

 

 

 

 

I haven't tried every single property, but so far it seems that the only property I can change (without it changing back) from within the AV is "SW-Material".

 

Halp plz!

 

Thanks,

Ramzi

Outcomes