Adan Akerman

Wacom Tablet + Pen Problem Solved, request for other tablet setup ideas

Discussion created by Adan Akerman on May 9, 2020

Hi! I'd like to share a solution I found to a problem as well as solicit advice from other people who've been using Solidworks with tablet + pen setups. I'm switching away from using a mouse to using a drawing tablet in the hopes of preventing RSI issues as well as enabling creative expression in non-Solidworks software.

 

tablet: Wacom Intuos Pro (medium size - it's a non-touchscreen tablet)

pen: Wacom Pro Pen 3d (gives a third button up near the grip area)

 

I'm also using a 3Dconnexion Spacemouse, compact

 

The problem: the Right Mouse Button Gesture Ring wasn't appearing. It was properly enabled, worked fine with a mouse, but when I click-dragged with the pen button I'd mapped to RMB click it would just create a selection rectangle.

 

The Fix: I disabled Windows Ink in the pen's mapping settings in the Wacom control panel. Apparently disabling this can cause other issues in software more dependent on pressure levels from the pen, but that's not currently (to my knowledge?) a supported feature for any SolidWorks functions.

 

Request: can anyone else who's using a similar setup make any recommendations for setup? I'm early in this process so I'm interested in everything from helpful key mappings to desk layout, etc. Even dumb stuff like what you do with your pen when you transition from tablet use to keyboard and back. It's a whole new world and awkward-going so far :-)

 

Thanks!

Outcomes