AnsweredAssumed Answered

My main problem is that when I use the Extract Machinable Features in Solidworks it recognizes some of the features of the part model that i have to machine but not all…

Question asked by Abdullah Bhutta on Apr 19, 2020

Hello,

My main problem is that when I use the Extract Machinable Features in Solidworks it recognizes some of the features of the part model that i have to machine but not all… you can see the following part that I made in Solidworks:-

image
image1161×656 76.3 KB

 

You guys can see that there is a lot of use of G02 and G03 commands but when I post the G-Codes these are no where to be seen and when i upload the G-Code file to my Machine it did not run smoothly it stopped and then after some delay of maybe a Second it started running again and this happened after every 2nd of 3rd command it executed and the machined part was not fully accurate there were small steps everywhere on the part…you guys can see the G-Codes that I made:–

N0 ( Flat Area1 )
N1 G90 G54 G00 X14.453 Y-51.395
N2 G43 Z5. H02 M08
N3 Z-5.
N4 G01 Z-8. F750.
N5 X14.325 Y-51.109 F1000.
N6 X13.575 Y-50.536
N7 X13.416 Y-50.406
N8 X11.331 Y-48.214
N9 X9.344 Y-45.932
N10 X6.537 Y-41.42
N11 X5.765 Y-39.606
N12 X4.594 Y-36.543
N13 X4.15 Y-34.903
N14 X3.642 Y-32.184
N15 X3.409 Y-30.914
N16 X3.32 Y-29.625
N17 X3.298 Y-50.007
N18 X3.427 Y-50.656
N19 X3.795 Y-51.206
N20 X4.344 Y-51.573
N21 X4.993 Y-51.702
N22 X14.124
N23 X14.349 Y-51.613
N24 X14.453 Y-51.395
N25 X13.46 Y-50.203
N26 X12.893 Y-49.593
N27 X11.594 Y-48.271
N28 X10.739 Y-47.305
N29 X9.881 Y-46.339
N30 X8.617 Y-44.407
N31 X8.031 Y-43.441
N32 X7.485 Y-42.475
N33 X6.936 Y-41.508
N34 X6.443 Y-40.542
N35 X6.047 Y-39.576
N36 X5.686 Y-38.61
N37 X4.954 Y-36.832
N38 X4.657 Y-35.712
N39 X4.424 Y-34.746
N40 X3.962 Y-32.275
N41 X3.709 Y-30.881
N42 X3.627 Y-29.915
N43 X3.597 Y-28.949
N44 X3.543 Y-27.983
N45 X3.382 Y-26.051
N46 X3.309 Y-25.385
N47 X3.341 Y-24.681
N48 X3.392 Y-24.193
N49 X4.215 Y-19.816
N50 X4.696 Y-18.152

Does this has anything do with the tolerance value ??? I have set the tolerance value to 0.00 mm…

Can anyone help please.?

Outcomes