AnsweredAssumed Answered

Jagged/pixelated/aliased text when Editting Sketches

Question asked by Ryan Feeley on Apr 6, 2020
Latest reply on Apr 6, 2020 by Ryan Feeley

[Edit: a fix may be to enable full-scene anti-aliasing in the System Options]

 

Hello everyone, quick question about the rendering of text in sketches for dimensions, notes, etc.

 

I frequently run into a situation when editing a sketch where it appears that the screen is being rendered with low quality. Perhaps the anti-aliasing is just not kicking in for some reason, although I think only the dimension text and arrows are affected. Has anyone else seen this, and if so, is there a way prevent it, or at least force a re-draw?


Here is an example: aliased text when editing a sketch:

But text appears fine when either selecting the sketch in the feature manager, or when a dimension is selected for editing.

 

In the case where the text is jagged during a sketch edit, I can fix it by selecting a sketch entity, and doing ctrl+R once or twice to force a redraw. But as soon as I move the cursor, the text is jagged again.

 

I'm on Windows 10, Solidworks 2019 SP05. NVIDIA P5000 Quadro with the R440 U7 driver (latest ODE). Here are my display settings:

 


Thanks everyone!

Ryan

Outcomes