AnsweredAssumed Answered

Selected Sketches Showing with Dashed Lines with Shaded Display

Question asked by Ryan Feeley on Mar 18, 2020

Hi Everyone,

 

Quick question about Solidworks display options. I'm using 2019 SP05.

If I'm in a shaded display mode (either with or without edges), and I select an existing sketch in the feature tree, any of the sketch entities that are within the volume of solid bodies (so those that are "hidden") show as dashed. Does this happen for everyone?

I would prefer that all sketch entities that are have unbroken lines in the sketch (i.e., non-construction) would appear with unbroken lines (i.e. be solid lines) when I select the sketch. Is there an option to enable this? The behavior that I'm seeing is a bit annoying when I have complicated sketches. These entities are unbroken if I hover/highlight a sketch, or if I make it visible. They are only dashed if I select the sketch in the feature manager. I think the most annoying aspect is that selecting a sketch that is visible instantly switches these lines from unbroken to dashed.

My current work-around is to add 1% transparency to my material appearance, but that seems like a hack. Solidworks has an option to display hidden edges as solid or dashed, but I don't see anything for displaying selected sketch entities.

Here's an example where I'm selecting a sketch in the feature tree. You can see the sketch is displayed as a mix of solid and dashed blue lines.

(Ignore that my colors are non-default. I use solidworks with the dark theme, and have the night mode enabled on my computer, so the default colors don't work for me.)

 

Outcomes