AnsweredAssumed Answered

Sketch on edit always zooms in to origin

Question asked by Paulius Lukauskas on Mar 4, 2020

Hi, I updated my solidworks from 2017 to 2019 SP5 and now I have this weird bug (or was it intended? I don't know...).

Basically, when ever I edit sketch of existing feature in model program zooms into origin to certain size every time. It doesn't matter how camera is positioned, where sketch is placed and what size that sketch is. I get always zoomed into origin view (around 200x200mm view).

 

Image 1 - general front view of full part (part size is 220x250 mm with origin on sketch bottom)

Image 2 - is how I edit sketch

Image 3 - is what view I get every time (approximately 200x200 mm around origin point)

Image 4 - is how sketch actually looks like.

 

If, for example, model is 10x10 mm size, when I edit sketch I get tiny sketch in middle of screen. But if I work with huge models, it always zooms me in to empty screen because of how big sketch is.

I didn't have this problem on older solidworks versions because in older versions editing sketches was always fit to screen sketch and I didn't need to use additional commands to zoom fit it myself.

 

"Systems options > Sketch > Auto-rotate view normal to sketch plane on sketch creation and sketch edit" is kind of an work around for this, but I still need to flatten sketch with additional command if I didn't do that on model.

 

My question would be: can I somehow change options so that every time I edit sketch, doesn't matter what size sketch is, I would always get flat and fit to screen whole sketch? 

Attachments

Outcomes