AnsweredAssumed Answered

Class not registered - CPPA certification

Question asked by Martin Jensen on Jan 27, 2020
Latest reply on Jan 27, 2020 by Martin Jensen

Hi SW forums

 

2 weeks ago I was attempting to take the CPPA certification (PDM professional admin).
The certification requires me to add an add-in for validation of answers. This add-in results in an "class not registered" error - not working, and therefore I was not able to get the validation code to answer the questions.
This thread is not to debate questions/answers specific to the certification - only the resulting error I get - which I assume is not intended for the certification.
I plan on trying the certification again this week. But if it gives me the same, or similar, CEX files including add-ins, I guess I'll get the same error.

 

Importing the CEX file (workflow, add-ins, users, groups etc.) gives no error.
When I access the created localview folder (root and subfolders) as well as right clicking the file explorer, I get the error "failed to extract add-in from "C:\........\{XXXX}\CEPA.CAF class not registered"
and this "Error loading add-ins. Message from database: class not registered"

 

the CEPA.CAF file does not exsist in the folder mentioned in the error window.
When I open the add-in from the PDM administration tool and click files, there is two files CEPA.dll" and "Interop.EdmLib.dll" - they are not in the previously mentioned folder, which I assume they should.
When I compare with my working vault where I have dispatch installed (working fine, no similar errors), I have the dispatch related files in the folder similar to where the CEPA.CAF (and those dll-files) should be.

 

I've done this to try resolve the issue, but still resulting in an error:
.NET framework is installed
Followed each step in this article: https://thegeekpage.com/solved-class-not-registered-error-in-windows-10
Tried setting up with the administration tool open as windows admin (I'm local admin on my PC)

Outcomes