Mark Biasotti

Insert part into part with constraint option bug

Discussion created by Mark Biasotti on Jan 9, 2020
Latest reply on Jan 13, 2020 by Mark Biasotti

I have seen this bug for a long time and my regret is that I did not SPR it while I was working for Dassault. I searched the forum briefly and could not see anyone else mentioning it. Here it is:

 

Often times when designing consumer products and working with the master model, I like to insert stock part/s into it so that I can more accurately lay out the internal structure (I then do a Delete Body on them just before my Save Bodies to avoid confusion or circular references). When I insert stock parts into my master part, I use the move/copy with constraints option to position them precisely where I want them and also to make quick changes parametrically.

 

The problem is that if I reorder feature before or after the inserted part, things start to fall apart. Often times if I'm editing a feature after the inserted part, the move/copy with constraints option that is absorbed by the insert part will not rebuild temporarily and the part is positioned in its inserted position as if the constraints are not applied. This is extremely frustrating as I'm trying to use this basic feature to build my models but the bug doesn't allow me to use it most times because this problem is most persistent.

 

Has anyone else experienced this problem?

 

Here is what the feature looks like

Insert Part with Constraint-Move/Copy

Here is the Part positioned in my model ( the small valve with ports)

Now when I edit this feature (RMB on below in my tree)  AFTER the inserted part feature (Boss-Extrude91)...

The insert part moves back to its default insert position (blue highlighted ) as if the constraints are not applied or rebuilt.

Now keep in mind that the insert part is not a child or parent of the sketch feature that I'm editing above. As a workaround I've tried inserting the part without the move/copy option and then did a separated move/copy feature on it after the inserted-part feature - to no avail, I still get the same behavior. This tells me the bug is with the Move/copy feature and not Insert-Part feature.

 

My hunch of what might be going on as part of the problem is the way that Move/copy is implemented in SW. I'd be surprised if they are using the D-cube constraint solver with this feature because, as far as I know, the D-cube solver is variational and feature rebuilds is sequential - i.e. D-cube solver in assembles solves all mates simultaneously. 

 

Anyway, I haven't file with my VAR yet because I find it hard this hasn't been reported?

 

thanks

 

Mark

Outcomes