AnsweredAssumed Answered

2019 PDM gets stuck and crashes during copy tree every time. 2017 was fine

Question asked by Clinton Clinton Grover on Nov 13, 2019
Latest reply on Nov 25, 2019 by Tim Webb

I have only tried copy tree about 3 or 4 times this year but so far every assembly I have tried has frozen the copy tree after about 2 or 3 parts. One particularly annoying feature is that the "copy" button in the copy tree dialog box remains faded if there are any files in the list that are not rebuilt. Could this seriously be the hang up? I have to toggle the check box next to the "offending" part to even be granted the option to copy the tree. In my current list of parts I'm actually deselecting the non-rebuilt part before copy tree and it still freezes. Usually there are no real changes to these parts other than checking in one of their references and there is no reason I should have to open and rebuild them.

 

I (and every one else in our company) build mostly sheetmetal parts with drawings named after the part. Typically if we are going to make a box we first make a solid shape and then insert that solid body into new parts and convert the box faces to sheetmetal. It has been the most robust and flexible workflow for us so far but I mention it because I wonder if that could cause some of the hangup to have multiple assemblies and parts that come from a common solid.

 

Anyone else have issues with copy tree that they didn't have last year?

Attached is my current lot in life

Outcomes