Jonathan Riel

Global Variable changes not reflected in model

Discussion created by Jonathan Riel on Nov 7, 2019
Latest reply on Nov 11, 2019 by Jim Steinmeyer

I'm still pretty new - studying for the CSWP and using an online course to do so.  I'm in SW 2018, and seem to have found some sort of glitch.

 

Last night the instructor went through global variables.  Seemed very easy... he created a few global variables in "Manage Equations", made a very simple sketch which referenced those variables for a few dimensions. Extruded the sketch into a solid. 

 

Then he went back into "Manage Equations" and edited the values of the GV's... and as soon as he clicked "ok", the model changed, as did the sketch of course. Very easy.

 

I recreated this model on my system and everything worked as expected until I tried editing the values of the GV's.  Exit "Manage Equations"... nothing happens.  Click rebuild several times... nothing happens.  Open the sketch... still showing the original dimensions.  Save, close, reopen the file... the "new" GV values saved and are visible in the design tree/"Manage Equations", but the model is still not updated!

 

The only way I could find to force it to update is to actually go into every GV linked dimension one at a time in the sketch... which seems to defeat the purpose of using GV's at all.

 

In "Manage Equations" I do have "Automatically rebuild" and "Automatic solve order" selected.

 

Any ideas?

Outcomes