Tom Gagnon

Merging extrude does not consider hidden solid bodies

Discussion created by Tom Gagnon on Sep 16, 2019
Latest reply on Sep 22, 2019 by Tom Gagnon

This is more of an observation than a question. Ref. 2018 SP5.

 

See attached file. I started a model of a wall box with its profile and anchor tabs, sketched and extruded. Then I used the same (Front as wall) plane and a new converted sketch from which to extrude the enclosure body. I hid the first body so that I was only selecting the sketch entities and not the body edges when converting. Then, I extruded the enclosure body and selected Merge result. It did not merge with the first body because it was hidden. When editing the 2nd feature, the Merge result check box was unchecked. Showing the 1st body revealed two overlapping bodies.

 

(Attached file stops there.)

Only once the 1st body was shown, could I actually edit the second feature to merge effectively.

 

Lessons:

1. Merge results only works upon visible bodies. Show what you want merged.

2. If you want to exclude a body from merging feature, but don't want to select which bodies to merge with, beforehand you can hide the ones you wish to exclude.

 

The opposite lesson from my initial problem, #2, could be useful if you have many things to merge with and very few things to not merge with. That is, hide the few and merge the many instead of selecting out the many in the feature scope options.

Attachments

Outcomes