AnsweredAssumed Answered

Anyone Else Encounter Rollback Error?

Question asked by Dennis Dohogne on Sep 9, 2019
Latest reply on Sep 10, 2019 by Dennis Dohogne

I just had this happen:

1. Top level assembly open

2. One subassembly open

3. One component of subassembly open and being worked on.  Component had been rolled back and then unrolled to bottom with new features added.

4. Got to subassembly and SWX says "A component is in rollback mode.  The assembly is currently unavailable."  Component IS NOT in rollback mode.

5. Go to component and close it.  Now only the top level and the subassembly are open.  Still get the same error.

6. Cannot do anything.  SWX is not even waiting to complete an operation.  Must KILL SWX from Task Manager.

 

Restart SWX and choose not to recover any of the files (since component was saved and assemblies are therefore up to date as soon as they rebuild on opening).  Everything is now fine.

 

If I had had a bunch of other files open (as is often the case) I would have potentially lost a lot of work.

 

I could not send in an error report since SWX did not see this as an error.  It is not reproducible so there was no point trying to record it.

 

I am on SWX2019 SP4.0, but I have had this happen before on a few occasions with SWX2016 (at least) to now.

 

 

Has anyone else had this happen to them?

 

 

Sometimes the thing that flashes in my head is "Must KILL SWX!"

Outcomes