John Ashton

Motion Analysis

Discussion created by John Ashton on Apr 13, 2009
Problem occurs using SW 2009 Premium, Windows XP 32 bit machine.
I have a Windows Vista 64 bit machine available but have not tried this simulation on it yet.

The assembly I am trying to apply motion analysis to consists basically of a four bar linkage system that is linked to two scissor type linkages. The assembly also contains a half sheet of plywood for the assembly to walk/crawl across, where only gravity, friction, and 3D contact link the assembly to the plywood. The scissor linkages are independent of each other. A single rotory motor is added to the assembly via SW motion program, and all of the assembly motion is derived via that motor.
I can make the assembly move in SW Animation. I can usually make the asembly move in SW Basic Motion however it seems if I try to use a motor and then also try to add 'gravity' problems begin to occur, i.e. moving assembly dissappears leaving only the red arrow that indicates rotory motor motion and also the plywood it is supposed to be moving on top of. With 'gravity' alone applied the assembly has moved as would be expected (usually).
If I try to use SW Motion Analysis I generally get the error message 'The initial conditions displacement failed'. It appears that the assembly is trying to initially instantaneously move to a beginning position that would align its' coordinate system with the plywoods' coordinate system. It has moved to that approximate position and actually worked on one or two rare occasions. Generally the model explodes into positions physically unattainable and/or pieces physically disconnect from each other. At this point it is difficult and sometimes impossible to get the model to rebuild to its normal configuration.
Note that the assembly contains zero reduntant constraints, I have tried increasing the initial integration step, decreasing minimum integration step, maximum integration step, and also tried all three solvers (and probably a hundred other nuances to the model or system parameters).

Any help would be appreciated.

Regards,
John Ashton

Outcomes