AnsweredAssumed Answered

Visualize Professional 2019 SP3 Video Driver Problem

Question asked by Bill Toft on Jul 20, 2019
Latest reply on Aug 4, 2019 by Bill Toft

I run HP ZBook 17 G2 (Win 7 Pro) with NVIDIA K3100M and Approved Driver 386.07. I have had NO video problems with Visualize since it came out and up to 2019 SP2. I recently upgraded to 2019 SP3 and SolidWorks runs fine.

 

My client asked me on Friday afternoon to render the SW Assembly I had completed for him that day (in 2019 SP3). He needs it by Monday AM because it is being included in a quote package they are doing.

 

Today I started up Visualize 2019 SP3 and got “Display driver stopped responding and has recovered” message and Visualize crashed. I went to the SW Driver Update page and see that the correct 2019 NVIDIA driver is 425.51, so I downloaded it.

 

I still had problems importing the assembly into Visualize (crashing), but I could open another project (done in 2019 SP2) OK. I found if I did “Save Advanced” from SW, then did a “Model Import” in Visualize, I could work in Preview mode without problems. I sent the views I wanted to Visualize Queue. Normally they should take 10-15 min. to render. But after an hour, the Queue still said Time Remaining is unknown.

 

So I quit the Queue and decided I needed to work in Fast mode to verify everything was OK. Then re-send to Queue. Now Visualize crashed every time and I got the  “Display driver stopped responding and has recovered” error.

I found a Microsoft page that suggested using regedit to add a “TdrDelay” key and set it to 8 (default is 2). Rebooted but still Visualize crashed. BUT I could open that 2019 SP2 project with no problems (in Fast mode!).

 

I have reported this to my VAR.), but this is the weekend so any ideas as to what I should try next?

 

PS I will be upgrading to HP Zbook 17 G6 (Win 10 Pro & RTX 3000) as soon as it becomes available (later this month).  But that doesn’t help me today . . .

Outcomes